Page 1 of 1

SW install on Mac problems

Posted: Sun Feb 12, 2017 10:27 pm
by wa2bfw
I have tried installing the API and Cubic SDR on my mac-mini with no success whatsoever.
When I run CubicSDR I get the SDR devices popup and there is no device that looks anything like my SDRplay rsp1. There is no indication that it's being detected when plugged in. I know it's not the SDRplay of the cable, because when both are used on a WInbook, they work fine.
I can't find any definitive instructions on how to troubleshoot things either.
When I run rtl_tcp SDRplay I get the following:
dyld: Library not loaded: /usr/lib/system/libsystem_coreservices.dylib
Referenced from: /Applications/rtl_tcp
Reason: image not found
/Applications/rtl_tcp line 4: 759 Trace/BPT trap: 5 ./sdrserver -d -s 2400000

Maybe someone can make sense of that and tell me what I need to do. I'm really trying to stay away from windows if I can.
Marv - wa2bfw

Possible Solution for Macintosh

Posted: Thu Mar 09, 2017 10:52 pm
by jwilliambaxter
Hello Marv,

I also had a bit of a learning curve, getting SDRplay (RSP2 Pro) to run with my MacBook Air, which is currently running Mac OS X Sierra 10.12.3.

The SDRplay Support folks were *great* and suggested deleting my current version of CubicSDR (drag to Trash) and then installing this one: ... Darwin.dmg

After this, simply plugging in the USB cable from the SDRplay resulted in it working beautifully with SDRplay!

Just install this version of CubicSDR, then launch it and if necessary select "File/SDR Devices". You may possibly need to click "Refresh" at the bottom of the popup, but if all goes well you will now see your SDRplay as a selection!

It works very, very well and is a dream come true. Absolutely amazing device - and I know I am only scratching the surface. Now exploring antenna options.

Many, many thanks to the team at SDRplay!

-john N3FPZ

Re: SW install on Mac problems

Posted: Sat May 06, 2017 10:25 am
by grantp
I tried this software and it saw the SDRplay device so thats great, however it crashed the instant I selected it. I am running 10.12.4 which is the latest OS and am also running on a new MacBook Pro with 4 Thunderbolt ports. Is there a later version of software anyone knows about?