linux mint18

Post your feedback here
ekimrolyat
Posts: 5
Joined: Fri Apr 13, 2018 3:32 pm

linux mint18

Postby ekimrolyat » Fri Apr 13, 2018 3:58 pm

I downloaded SDRplay_RSP_API-Linux-2.11.1.run into Linux Mint18 (I don't run Ubuntu) and used the GUI to make it executable, then ran it. It said it succeeded in installing something, then dropped me back to the command line. I can't figure out what to do next. I tried various command line commands without success. I looked throughout my file browser and GUI menu but can't anything that looks even vaguely like the right thing.
So, one question is, assuming it's in there somewhere, how do I find it?
Thanks,
Ekim
Last edited by ekimrolyat on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 794
Joined: Wed Jan 07, 2015 7:58 am

Re: linux mint18

Postby sdrplay » Fri Apr 13, 2018 8:42 pm

If the API installation has succeeded, you will see it in the /usr/local/lib directory (libmirsdrapi-rsp.so.*)

After that you need to install whatever SDR software you want to use. We recommend CubicSDR and the AppImage you could try is on our Downloads page (https://www.sdrplay.com/downloads)

Best regards,

SDRplay Support

Reason: No reason

ekimrolyat
Posts: 5
Joined: Fri Apr 13, 2018 3:32 pm

Re: linux mint18

Postby ekimrolyat » Sat Apr 14, 2018 2:42 pm

Well, that did it. Thank you very much. Beautiful screen. suggest leaving this mssg for future Linux Minters.
Last edited by ekimrolyat on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

ekimrolyat
Posts: 5
Joined: Fri Apr 13, 2018 3:32 pm

Re: linux mint18

Postby ekimrolyat » Sat Apr 14, 2018 10:21 pm

ok, sorry to keep bothering you, but now I get no sound. I have the thing set to my local weather frequency (162.400) and I get no sound despite a very convincing-looking waterfall. I checked with another radio and they are indeed on the air. Also, the waterfall pattern does not change - at all - when I disconnect the RSP1A from the usb.
Sorry to seem like such a dweeb, but there is no antenna under that red plastic cover. I presume that might be the problem but I find no instructions anywhere about what kind of antenna to connect and where to get it.
Thanks, Ekimrolyat
Last edited by ekimrolyat on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

jon
Posts: 362
Joined: Tue Jan 06, 2015 10:48 am

Re: linux mint18

Postby jon » Sun Apr 15, 2018 6:05 am

Hi Ekim,

under the red cover is the antenna socket which, in radio terminology, is a 50 Ohm impedance input. This means that an antenna is needed.

You can either connect an antenna directly to this antenna socket, or indirectly by having a length of coaxial cable( see https://en.wikipedia.org/wiki/Coaxial_cable which allows you to connect the antenna some distance from where the RSP unit is located. Lower frequencies will also be prone to noise and wire antennas for them, need to be physically much bigger than can comfortable be accomodated indoors.

The reason you might want to add a length of coaxial cable is that if you are deep indoors he signals will be significantly weaker than having the antenna outdoors/ higher up in the open.

The simplest, optimum, non directional antenna you can have is a quarter wavelength of conductive wire - here's a calculator which converts frequency to length of wire (metric versions are also available) http://www.csgnetwork.com/antennagenericfreqlencalc.html

So for 162.4 MHz, a length of wire 2.34 feet (71cm) is ideal. In practice exact measurements don't matter too much, which is why a telescopic whip antenna will work quite well from 50 MHz to several 100 MHz.

So if you're already getting strong signals on another indoor receiver, the simplest thing to do is to connect a length of wire to the centre connection of an SMA plug and screw it onto the antenna socket. Many people use an adapter to a chunky SO239 socket which then allows them to insert a bent over wire or banana plug directly into the centre. See this old video, 1 minute 30 seconds in, which shows connecting to the centre of the SMA socket https://youtu.be/TJSctUv5lUc

See also the antennas section of this forum - or post your questions on antennas there. You can also get help from the independent Facebook group on https://www.facebook.com/groups/sdrplay

Good luck, Jon

Reason: No reason

ekimrolyat
Posts: 5
Joined: Fri Apr 13, 2018 3:32 pm

Re: linux mint18

Postby ekimrolyat » Mon Apr 16, 2018 4:00 pm

ok, thanks Jon, got the antenna sorted out, have an antenna that gets 5 by 5 full quieting on my HT (weather channel. as advised). But, transferring the antenna to the RSP1aA, - no reception from the RSP1A. Lots of static but no voice. No change in the waterfall or static with removing the RSP1A from the USB plug.Two different USB cables, both known to be working.
Is there something simple I need to check, or is it just broken? I looked at the list of rigs and there is no RSP1A choice. Hoping for something simple, not looking forward to returning the device for replacement. And thanks for all your help so far.
Last edited by ekimrolyat on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Tech_Support
Posts: 336
Joined: Mon Jun 01, 2015 7:00 pm

Re: linux mint18

Postby Tech_Support » Mon Apr 16, 2018 4:15 pm

Hello Ekimrolyat,
I suggest you open up a support ticket on www.sdrplay.com/support and we will try to help you out. Please let us know exactly what you have installed when you do so.

Sincerely

SDRplay Tech_Support

Reason: No reason

ekimrolyat
Posts: 5
Joined: Fri Apr 13, 2018 3:32 pm

Re: linux mint18

Postby ekimrolyat » Mon Apr 16, 2018 5:20 pm

It won't let me in. I tried 5 times. Here's what I tried to send:

I have installed SDRplay_RSP_API-Linux-2.11.1.run in Linux Mint, everything seems ok. I installed CubicSDR-0.2.3-x86_64.AppImage on your advice and everything looks ok. I have installed a known working antenna that gives me good voice with full quieting on an adjacent HT. When transferred to the RSP1A in gives no reception using NBFM and the local weather frequency (the one giving good voice on the HT). I have three USB cables, all previously know to be working, tried all of them, no effect.

OK, in desperation I went over to Win7 and installed SDRuno as per your video. Everything looks ok on the install but it reports that it cannot find the RSP1A and suggests I check the USB cables, drivers etc.

It appears at this point that the RSP1A arrived in non-working order. I'm still hopeful that there's some small thing I can click to make it right. If not, can you tell me how to go about getting a replacement?

Thanks, Ekim
Last edited by ekimrolyat on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Tech_Support
Posts: 336
Joined: Mon Jun 01, 2015 7:00 pm

Re: linux mint18

Postby Tech_Support » Mon Apr 16, 2018 10:41 pm

Hello Ekim,
I have no idea why you can't open a ticket. Please send an email to support@sdrplay.com listing your issues and we will open a support ticket for you once we have your email address. All RSPs are fully production tested so it would be unusual for yours to be non-functional.

Sincerely

SDRplay Tech_Support

Reason: No reason


Return to “New Users' experiences”

Who is online

Users browsing this forum: No registered users and 3 guests