Page 1 of 1

SDRUno will not work on VMWare FUsion

Posted: Thu Aug 31, 2017 8:40 pm
by n5zap
So installed VMWare Fusion and Windows 10 on my iMac in the hopes that I could use SDRUno. So far, no dice. The application installs, and when I plug in my RSP1 I get the jingle in Windows that says a new USB device is installed, but Windows never installs drivers. When I try to run SDRUno I get a "RSP not found, check cable" message. I know others have gotten this to work, but how do I get drivers loaded?

I've tried moving to different USB ports, uninstalling and reinstalling as Administrator, but still no love. I have installed several other applications that use special serial port drivers and they all work just fine, just SDRUno is broken. How should I go about troubleshooting this?

Re: SDRUno will not work on VMWare FUsion

Posted: Sun Sep 03, 2017 9:54 am
by vk7jj
I know I'm late to this and you may have given up or fixed it.

I solved that problem by setting the SDRPlay as a USB2 device in VMWare. (BTW I'm using an RSP2)

VMWare Menu: Virtual Machine > Settings... > USB & Bluetooth > [click on the SDRPlay device] > Advanced (the tiny down arrow) > USB Compatibility 2

In addition, after Windows 10 boots in your VM and is ready to use, unplug the SDRPlay USB cable and plug it in again; as you noticed it gives a little chirrup noise. Seems that the device drivers aren't loaded when Windows 10 boots, only when the hardware is unplugged and replugged, probably a VMWare issue.

Apart from that it works very well: iMac (27-inch, Mid 2011), 2.7 GHz Intel Core i5, 8 GB RAM, allocating 2GB RAM and 2 cores to the VM runs SDRUno at 10MHz without audio jitter, though normally I don't do that. It does make the Mac OS significantly less responsive but still viable for simultaneous use.

Good luck.

Re: SDRUno will not work on VMWare FUsion

Posted: Wed Oct 11, 2017 9:51 pm
by n5zap
Thanks! I was just coming on to tell folks that setting to USB2 fixes it. I appreciate your getting back to me, and hope you have a great day!

VMWare Fusion is the bee's knees. I have all of my Ham software running in a VM. So much better than keeping a second computer on the desk.

Re: SDRUno will not work on VMWare FUsion

Posted: Sat Aug 18, 2018 7:13 pm
by ve7gel
The same solution solves the same problem with VMWare on Fedora 28.