Page 1 of 4

SDRUno 1.2 issues

Posted: Sun Oct 29, 2017 7:39 pm
by pgoelz
First of all, I thoroughly appreciate the work that went into SDRUno.... my favorite SDR program with the RSP2.

That said, I am finding quite a few issues (most of them new) in version 1.2, as follows. I hope this is an appropriate place to provide feedback.

1. The update process (installing over the top of the previous version) deleted all my carefully arranged workspaces and I had to re-create them from scratch. A process made much harder by issue #2....

2. The process of saving a workspace is very flakey... or maybe I am missing something? Seems now the only way to save a workspace is to press CTL-W and I can no longer simply control click the desired workspace in the list to save my arrangement to that workspace? Trouble is that CTL-W does not always bring up the list of workspaces.... it seems as if the save routine requires a change to the workspace before it can be triggered. Unfortunately, it does not always recognize a moved or re-sized window or the presence absence or the memory panel (for example) as a change and does not respond to CTL-W.

3. I miss the VFO CENTER button on the main waterfall. I guess I can click a zoom button and then click the opposite zoom button to in essence center the VFO without changing the zoom level but the VFO center button was very handy.

4. Frequency steps are inconsistent. For example, if I switch from LSB to SAM, the step size remains at 250 Hz instead of changing to 1KHz. Apparently, SAM does not command a frequency step and the step size remains what it was prior to clicking SAM.

5. The buttons and window borders do not always re-draw correctly. The borders of the memory panel are prime offenders, as are the buttons in the main waterfall window.

6. For some reason the text in the memory panel often switches from yellow to black, making it much more difficult to read against the dark background. This seems to happen in tandem with failure to re-draw window borders.

7. The text in the list of workspaces can get mangled if you switch from an RDP session to a local session without first terminating SDRUno. The only way to clear it is to terminate SDRUno and re-start.

The following are not bugs per-se, but would be highly desirable features:

1. I STRONGLY REQUEST that the step size for EACH MODE be user selectable. For example, I would prefer 1KHz for USB / LSB and 5KHz for AM and SAM. The current defaults are workable but not ideal for me.

2. I STRONGLY REQUEST that zoom level and/or sample rate / decimation be stored per memory slot so the display bandwidth can be recalled per memory.

Paul

Re: SDRUno 1.2 issues

Posted: Sun Oct 29, 2017 8:14 pm
by pgoelz
Another issue.... this one had me stumped for a while.....

If you click one of the ham band buttons, the sample rate and decimation change to center the ham band on the waterfall. Good so far. But this also activates LO LOCK, which REMAINS ACTIVE if you subsequently click a memory channel. The effect is that the mode and bandwidth change per the memory channel but the frequency does not. This had me going until I noticed LO LOCK was active and I suspect it will confuse many people until they figure it out. Not sure if this is new behavior, but I don't recall it happening on the previous version.

I also find it undesirable that the sample rate and decimation change when you click a ham band button and remain at those values if you then click a memory channel but I can't suggest an easy alternate..... it would be desirable that they at least return to their previous state before a ham band button was clicked but that sounds hard to code?

Paul

Re: SDRUno 1.2 issues

Posted: Sun Oct 29, 2017 8:19 pm
by pgoelz
it seems as if the save routine requires a change to the workspace before it can be triggered. Unfortunately, it does not always recognize a moved or re-sized window or the presence absence or the memory panel (for example) as a change and does not respond to CTL-W.


OK, I figured it out. The problem is that changes to the memory panel location and size do not enable a workspace save..... change any window EXCEPT memory panel and you can invoke a save with CTL-W. Change the memory panel and you cannot invoke a save with CTL-W.

UPDATE:
Further testing finds that the issue is simply that CTL-W has no effect if the memory panel has focus. If any other window has focus, CTL-W does invoke the workspace save window.... regardless of whether the window has changed. So maybe not a bug, but at least confusing (to me, anyway).

Paul

Re: SDRUno 1.2 issues

Posted: Sun Oct 29, 2017 8:49 pm
by pgoelz
Another one.....

Twice now, the waterfall, the IF display and the received audio did not agree. So far, I have not figured out what triggers it.

For example.... I was listening to a 40M SSB station on LSB. Initially, the main, IF and audio all agreed with his signal showing on both displays and in sync with the audio. At some point (not sure what triggered it), neither the main waterfall nor the IF waterfall agreed with the receive audio. I was still listening to the same LSB station, but he no longer showed on either waterfall. The main waterfall showed nothing within or even near the passband (even zoomed in). The IF waterfall did not show his signal but DID show what looked like an AM station with its carrier just outside the passband and plenty strong enough to have been visible on the main waterfall.

So far, this has me stumped. I'll try to figure out what triggers it. A day later and it has (so far) not recurred.

Paul

Re: SDRUno 1.2 issues

Posted: Mon Oct 30, 2017 6:51 pm
by Mike2459
It also appears that the CW mode ZAP feature is broken. It was a very useful tool in SDRUno

Re: SDRUno 1.2 issues

Posted: Tue Oct 31, 2017 1:46 am
by Mike2459
CW AFC does not work either. Tune to a carrier and center it in the passband in CW mode, Enable CW AFC and listen as the AFC begins driving the tuned freq. lower and lower.

Re: SDRUno 1.2 issues

Posted: Tue Oct 31, 2017 10:04 am
by Tech_Support
Hello Mike2459
We can confirm that this function has been broken in release 1.2. Thank you for flagging this.

Sincerely

SDRplay Tech_Support

Re: SDRUno 1.2 issues

Posted: Tue Oct 31, 2017 1:18 pm
by alantlk
Re post from Paul 29 Oct 8:49pm

I also found a disconnect between spectrum, waterfall and audio - strong readable audio, nothing displayed in the waterfall nor on the spectrum. Only once in that session on Sunday evening, but haven't tested since then.

I've only just bought a RSP2Pro and thought it was me doing something wrong!

Alan G0TLK

Re: SDRUno 1.2 issues

Posted: Tue Oct 31, 2017 1:45 pm
by Tech_Support
Hello Folks,
If you are able to identify the specific sequence that leads to these problems, it would be enormously helpful. Until we can re-produce the effect, we stand no chance of finding a fix for it. Thus far, none of either our internal or external beta testing team has yet observed the problem that has been flagged with the waterfall.

Sincerely

SDRplay Tech_Support

Re: SDRUno 1.2 issues

Posted: Tue Oct 31, 2017 2:11 pm
by alantlk
At this stage I don't know - was just fiddling around with the software. I thought it odd at the time and switched off, but didn't pay it much attention until I saw Paul's post yesterday.

Will have another go and see if I can provoke it again. I've done testing and bug hunting myself and agree it's almost impossible to find causation without the activity sequence leading up to manifestation!

Alan G0TLK