frequency selection glitch in 1.22

Discussions about everything to do with SDRuno
mark.
Posts: 38
Joined: Tue Oct 03, 2017 9:14 pm

frequency selection glitch in 1.22

Postby mark. » Fri Jan 26, 2018 8:12 pm

Earlier today I fired up SDRuno 1.22 as I have since it was released. After pressing PLAY I did the usual click in the main FFT window to create an LO offset. The cursor/verticle line would not move unless I clicked at least 50khz away from the present cursor. So I clicked further away to create the LO offset. Then I dialed in my frequency of interest with the mouse scroll wheel. Fine so far.

Now when I click to change frequency from the main FFT display window, it won't accept any click less than 50khz away from where it is presently at. And when I click a frequency further away it actually selects a frequency exactly 50khz above where I clicked. For instance, if I'm at 15mhz I have to click above 15.050 before the frequency will change. So lets say I click on 15.1mhz. SDRuno will go to 15.150khz

I restarted SDRuno, glitch still there. I rebooted my comp, the glitch still there. The only thing added to my comp in the last 48 hours is the usual security patchs that come from Microsoft every few days. SDRuno was working fine yesterday evening when I shut down. But this morning the glitch appeared.

Has anyone else run into this yet? I'm running Win7 64 bit.

Reason: No reason

mark.
Posts: 38
Joined: Tue Oct 03, 2017 9:14 pm

Re: frequency selection glitch in 1.22

Postby mark. » Fri Jan 26, 2018 8:22 pm

I just found out if I click on a ham band preset and try to scroll frequencies with the mouse wheel, it will jump in 50khz increments. So this whole thing seems t be centered around 50khz somehow. I guess I will uninstall and reinstall version 1.22 and see if the glitch goes away.

Reason: No reason

Tech_Support
Posts: 341
Joined: Mon Jun 01, 2015 7:00 pm

Re: frequency selection glitch in 1.22

Postby Tech_Support » Fri Jan 26, 2018 8:38 pm

Hello Mark,
Check what frequency step you have set. It sounds like it might be set to 50 kHz. You cannot select a change in frequency of less than the frequency step size when clicking with the mouse. You can however scroll the frequency by any decade step from 1 Hz upwards by simply hovering your mouse over he appropriate frequency column on the VFO frequency display and scrolling with the mouse wheel.

Sincerely

SDRplay Tech_Support

Reason: No reason

mark.
Posts: 38
Joined: Tue Oct 03, 2017 9:14 pm

Re: frequency selection glitch in 1.22

Postby mark. » Fri Jan 26, 2018 10:40 pm

Before I read your post I discovered the 50khz jump is only in AM and USB. That lead me to believe the issue is somehow my step sizes got changed. Seeing as how I don't know where to change steps manually and I had no reason to, I don't think I ever did. But I'll go look in the instructions on how to do it and set them back to defaults.

Thanks for the quick reply.

Reason: No reason

g1hbe
Posts: 350
Joined: Sat Jan 17, 2015 3:28 pm
Location: Cheshire, UK

Re: frequency selection glitch in 1.22

Postby g1hbe » Sat Jan 27, 2018 12:01 am

I've found that the step size on USB is set to 100KHz randomly. I'm not sure what causes it.

Reason: No reason
Andy

mark.
Posts: 38
Joined: Tue Oct 03, 2017 9:14 pm

Re: frequency selection glitch in 1.22

Postby mark. » Sat Jan 27, 2018 3:18 am

I never changed mine either, as far as I know. I still don't know how. Instead I just clicked the restore default settings for SDRuno. We'll see if it happens again somehow. At least I know I'm not the only one its happened to.

Reason: No reason

Tech_Support
Posts: 341
Joined: Mon Jun 01, 2015 7:00 pm

Re: frequency selection glitch in 1.22

Postby Tech_Support » Sat Jan 27, 2018 5:54 am

There is a bug on 1.22 in some of the sub modes of FM I am afraid. It resets the step size to 100 kHz. It only does this in FM mode. It will be fixed in 1.23. You change the step size by right clicking with your mouse over the frequency display in the Rx Control panel. You can then select the step size from a drop down list. it is covered in the manual.

Sincerely

SDRplay Tech_Support

Reason: No reason

mark.
Posts: 38
Joined: Tue Oct 03, 2017 9:14 pm

Re: frequency selection glitch in 1.22

Postby mark. » Tue Feb 06, 2018 10:43 pm

It happened to me again. I was listening to the RSP1 in AM mode with everything working fine up to that time,then shut down SDRuno then shut down the computer. A few hours later I started the computer, started SDRuno, pressed play, clicked to give about a 30khz VFO offset and I couldn't. The step size seemingly changed itself once again to 50khz just like in my previous post.

Reason: No reason

AlK2ZN
Posts: 2
Joined: Sun Mar 04, 2018 2:38 pm

Re: frequency selection glitch in 1.22

Postby AlK2ZN » Sun Mar 04, 2018 2:54 pm

Hi

New RPS2Pro user here. I just encountered this problem for the first time last night; the step size is affected, regardless of mode used.

Here's how I got it to occur:

Start with freshly-reset installation of SDRUno.

Fire up the radio and pick any mode other than FM; note the step size, e.g. 500 Hz for USB.

In the FM Mode section, select a bandwidth other than what's currently enabled. The step size will change in accordance with the default for the selected FM mode. That is, the 500 Hz step for USB becomes 100 kHz when WFM is chosen.

The only way I've been able to get the non-FM default step sizes to return to their original values is to issue another reset. At least, I haven't found another way yet.

Al
Last edited by AlK2ZN on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Paul
Posts: 236
Joined: Fri Feb 17, 2017 9:52 am

Re: frequency selection glitch in 1.22

Postby Paul » Sun Mar 04, 2018 5:15 pm

Hi Al
Fairly new to this as well.
If I understood your post correctly, this is how to do what I believe that you want to do.
In whatever mode you may be, simply right-click to the left of the tuned frequency shown in the "RX Control Panel" and a drop-down list of frequency steps will appear.
Simply select (click on) that which you would prefer and hey presto...
Have fun!

Reason: No reason


Return to “SDRuno”

Who is online

Users browsing this forum: No registered users and 8 guests