Page 1 of 1

SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Sat Apr 27, 2019 12:50 am
by RickF
I finally got SDRUno extio version to connect to my other PC that has the RSP1A connected and is running RSP-TCP. I had to uninstall all the SDRPlay software I have installed over the last few weeks and install the 1.22 version, along with ExtIO_RSP_TCP.dll of course. Until then, the extio version of SDRUno wouldn't even start, it just errored out instantly.

I started the server with "rsp_tcp.exe -E -a -b 16", started SDRUno-Extio on the other PC, put that IP address into the Opt/Select Input/RSP-TCP settings and left everything else at default. It seemed to work.


When I press play, there is nothing shown on the spectrum window, and no sound. As if they are completely inactive. I'm used to using SDRUno with the RSP1A connected to the PC directly so I know what to do and expect, usually. However I've only had the RSP1A for two weeks, so maybe not.

I can see the connection being made ("client accepted" etc.) on the RSP-TCP cmd window on the server PC. I can see the frequency being set there too if I change it in SDRUno's tuner, and see plenty of data (~8MB/s) coming in on my PC's network monitor as soon as I give SDRUno the IP address of the server. It looks like everything is working.

But no output.

What am I missing?

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Sat Apr 27, 2019 11:45 am
Hi, I am trying to reproduce your problem as I recently purchased RRSDuo and I set up the RSP TCP server on raspberry PI 3B+. The server is running OK and I can connect without problems with HDSDR, however, I am not able to force the extio version of sdruno to "see" the "ExtIO_RSP_TCP.dll". When I run the "SDRuno.EXTIO.exe", under options/select input i can't see any extio plugin (no extio rsp tcp). When I go to "settings" (the button on the sdr window upper left corner named "SETT." and i go to "INPUT" tab, there is written at the bottom - "No ExtIO.dll found". I have the "ExtIO_RSP_TCP.dll" copied in the same directory of course. So I need to get past this point to help you reproduce you problem - maybe you can help me.
Thanks a lot,
Ondrej, OK2TOP

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Sun Apr 28, 2019 8:23 am
by StandingWave
RickF, could this be down to antenna selection? I think RSP_TCP has a command line flag (-P I think) to select the antenna if you are using something other than the default port. AFAIK, the RSP_TCP Extio DLL is not supported with SDRuno versions 1.3 and 1.31, but it was my understanding that these newer versions could be installed into a separate program directory to avoid a conflict with the older version.

Ondrej, SDRuno.Extio.exe requires the Extio_RSP_TCP.dll file to be in the user Documents folder rather than the program folder.

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Sun Apr 28, 2019 9:43 pm
by RickF
StandingWave wrote:RickF, could this be down to antenna selection?
I don't think so. The RSP1A only has one (A), and the default is -P 0 which is port A.

However, I then tried taking out the -b 16 and SDRUno worked, albeit in 8-bit. The change was obvious in my bandwidth monitor - half the data coming in.

Seems a bit strange that I can't use the full bit depth of the RSP in its own software though. Maybe I'm missing something still...

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Mon Apr 29, 2019 10:52 am
by StandingWave
Sorry, I have the RSP2 which has 3 antenna ports and I had run into this problem, but I didn't realise that the RSP1A has only one antenna port. That being the case, it definitely can’t be down to antenna selection then.

Its curious about the 16 bit mode though. Maybe -b 16 doesn’t work because the RSP ADC bit rate is not quite 16 bits, but 14. Looking at the RSP TCP server notes maybe you don’t need to specify the -b parameter at all:
When the server is run in standard mode, it will be compatible with the RTL TCP protocol. When the server is run in extended mode, all of the features of the RSPs become available and the full ADC bit rate up to 14bits is supported. The extended mode requires the use of a compatible client (such as the ExtIO plugin you can download from our Downloads page, along with the RSP TCP server software)
So maybe -E is all you need to run with the full 14 bits supported?

I have never used the -b parameter myself, but perhaps by specifying -b 8, although it works, you are forcing the server to 8 bits? I would like to know myself at what bitrate my SDRuno and HDSDR setups are actually receiving data with but am not quite sure where/how I can check this?

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Mon Apr 29, 2019 6:52 pm
by RickF
StandingWave wrote:Looking at the RSP TCP server notes maybe you don’t need to specify the -b parameter at all:
That would make sense, but doesn't seem to be the case. When I ran it with "-b 16", I saw about 8MB/s data as soon as I gave SDRUno the IP address, despite that it then gave me no output. So the server and TCP dll are working...

I'm slightly guessing here, but: 2MS/s * 16bits * 2 (because I and Q) = 8MB/s ... seems to fit.

When I removed the "-b 16" (I did not do "-b 8", just removed it) but still had -E in, the data rate halved. That fits with 8 bits. Then though it actually gave an output on the display and sound.

It looks like SDRUno itself is not processing the 16-bit stream. I've not found anything, anywhere in SDRUno to change or give information about this. Since my main aim was to remote the RSP in the loft, from my living room, I'm quite keen to get this working.

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Tue Apr 30, 2019 7:03 pm
HAVE the same problem SDRuno EXTIO not starting. I also have 1.31 installed and I'm not about to go backwards just for this issue. In the end I've come to the conclusion that remote SDRplay is simply not well supported (note no SDRplay support input to this thread at all for example). The TCP server is very clunky and slow although I have got it to work with HDSDR.

In the end I've gone over to kiwiSDR plugged into a Beagelbone. It has none of these issue and just works seamlessly remotely as it's essentially designed to do that with an embedded webserver. I bought my SDRplay to use remotely as my home location is very RF noisy. A mistake really as I want to listen to signals not have to become a network guru. The kiwiSDR is working really well and all I had to do was run it and open the required port in the firewall. All this messing about with versions of this and that and different directories etc. not to mention that the end result is pretty ineffective communication between client and server anyway so not worth it in the end. SDPplay did mention great plans of a proper remote capability in SDRuno for SDRplay but no commitment as to when.... if ever in reality.

Re: SDRUno extio to RSP-TCP - what am I doing wrong?

Posted: Thu May 02, 2019 10:44 am
Hi, but don't foget that KiwiSDR is only a HF receiver (up to 30MHz max) as th RSP is up to 2GHz. I owned the KiwiSDR too and it was a great performer on HF, however I wanted to monitor also higher bands so I sold the KiwiSDR and purchased RSPduo. I am totally happy with the RSP. I have managed to get the Raspberry PI 3B+ and RSPduo working remotely and connect wia the 1.22 version of SDRuno and EXT_IO TCP plugin. The max bandwidth is about 2MHz via TCP, which is OK.
I suggest to look at the SDRuno roadmap here: ... -road-map/
It looks like they are working on the re-worked native support for remote client version in version 1.41, so let's hope it will turn out to be true soon.