Odd behaviours spotted so far.

Discussions about everything to do with SDRuno
g1hbe
Posts: 195
Joined: Sat Jan 17, 2015 3:28 pm
Location: Cheshire

Odd behaviours spotted so far.

Postby g1hbe » Wed Jun 22, 2016 3:13 pm

Early days and all that. I'm getting severe AGC 'bouncing' under certain conditions. If I'm tuning the AM (MW) broadcast band with the LNA off, and I click the AGC to ON, the spectrum display starts to jump up and down and the audio thumps. Sometimes it settles down, other times it just carries on.

The other one I've already mentioned. At the VLF end of the coverage, behaviour is erratic. Sometimes there is a discrepancy between the digital frequency readout and the actual reception, at other times the software ignores my input completely. Note this only seems to affect frequencies below about 100 KHz.

I also think it may be a good idea to have the Uno software start up in some kind of usable single-receiver mode straight out of the box. To be confronted with the tiny 'main window' on first start up is a bit daunting, probably quite unnerving for a novice. My first thought on seeing it was 'oh no, something is wrong!'
Last edited by g1hbe on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Andy

User avatar
lhuchison
Posts: 1
Joined: Tue Jun 14, 2016 12:10 am

Re: Odd behaviours spotted so far.

Postby lhuchison » Wed Jun 22, 2016 7:29 pm

i noticed the same bouncing on AGC with LNA off and AGC on. very strange! Totally agree about the start up window. I feel it needs to have the whole thing start ,then you can play with positioning after you worked it all out.
Last edited by lhuchison on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
New SDR user

DaveB
Posts: 129
Joined: Sun Feb 01, 2015 6:04 pm

Re: Odd behaviours spotted so far.

Postby DaveB » Wed Jun 22, 2016 9:10 pm

I've noted the same bouncing initially - but now can't reproduce it.

When saving a workspace I would really, really, like it to save the size and position of the pop-up windows that I've opened at that point. Then next time I open it everything is where I want it. With a choice of ten workspaces you can have different ones for different modes eg FM DX, MW DX, Short Wave.

I'm sure the SDRPlay will get lots of suggestions!
Last edited by DaveB on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Jim-Mn
Posts: 6
Joined: Sat May 21, 2016 9:44 pm

Re: Odd behaviours spotted so far.

Postby Jim-Mn » Wed Jun 22, 2016 10:20 pm

Once you open SDRuno and get the windows arranged as you like them, go back to the first window that pops up when you opened SDRuno and at the bottom center, left click on the word Default Workspace, then hold the Ctrl key and left click on Workspace 1. This will save all of the window sizes and positions that you have selected
Last edited by Jim-Mn on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

g1hbe
Posts: 195
Joined: Sat Jan 17, 2015 3:28 pm
Location: Cheshire

Re: Odd behaviours spotted so far.

Postby g1hbe » Thu Jun 23, 2016 8:17 am

Yes Jim - but on first installation and use, all you get is that tiny window and you have to start fiddling about to make it work. An 'out of the box' working default receiver with the basic windows in place would make life a lot easier, especially for newcomers to SDR.
Last edited by g1hbe on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Andy

Jim-Mn
Posts: 6
Joined: Sat May 21, 2016 9:44 pm

Re: Odd behaviours spotted so far.

Postby Jim-Mn » Fri Jun 24, 2016 2:54 am

On the AGC chuffing: On the main window (when you first open SDRuno) between AGC and PERF there is an ADV option. Click on that and hover over the ADC SP; It's set at -30. I lowered mine to -28, and that seemed to stop the chuffing of the AGC. If that doesn't work, try different levels.
Last edited by Jim-Mn on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

g1hbe
Posts: 195
Joined: Sat Jan 17, 2015 3:28 pm
Location: Cheshire

Re: Odd behaviours spotted so far.

Postby g1hbe » Fri Jun 24, 2016 6:54 am

I've tried that, Jim. I first increased it to -40 and that seemed to stop it, but it started again later. So I took it the other way and once again it stopped...then came back. I seem to recall that in its early days, the SRP had this problem with SDR# but was corrected with updates to the EXTIO file.
Last edited by g1hbe on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Andy

DanubeBCL
Posts: 160
Joined: Sat Jul 02, 2016 12:39 pm

Re: Odd behaviours spotted so far.

Postby DanubeBCL » Sat Jul 02, 2016 1:15 pm

Reading this comforts me (a bit). At least I know my SDRPlay is not defective. When I saw this random hopping of the (hardware) AGC I had thought I received a defective rig.
Meanwhile I keep fingers off the AGC and RSP Gain Reduction. Every time I use these my spectrums hops up and down from bottom to ceiling. Sometimes all signals seem to disappear completely. The only way to restore reception I found is to Press Stop and Play. After this the spectrum seems to be stable for a while.
I also experienced that using AGC and GR sometimes reverts the I/Q channels out of nothing. Suddenly all stations are on the "other side" of center and tuning direction is reversed. This gave me total confusion at the beginning because I did not know if I should choose Swap I/Q or not. Pressing Stop and Play when this happens also brings back normality (till the next glitch).
73s, Heinrich
Last edited by DanubeBCL on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “SDRuno”

Who is online

Users browsing this forum: No registered users and 1 guest