Feedback for version 0.9a here

Information and discussions on Spectrum Analysis
sdrplay
Posts: 809
Joined: Wed Jan 07, 2015 7:58 am

Feedback for version 0.9a here

Postby sdrplay » Tue Jun 12, 2018 10:57 am

Please use this thread to post feedback on the 0.9a release

Please read previous comments to make sure that only unique issues are posted. This will help Steve to keep track and fix them. Duplicate posts of the same entry may get removed just to keep this thread focused.

Best regards,

Andy

Reason: No reason

JohnAE5X
Posts: 8
Joined: Fri May 11, 2018 6:50 pm

Re: Feedback for version 0.9a here

Postby JohnAE5X » Tue Jun 12, 2018 1:03 pm

Any idea as to how long before the SDRduo is supported?

Tnx,

John AE5X
https://ae5x.blogspot.com
Last edited by JohnAE5X on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

JayDubya
Posts: 3
Joined: Tue Oct 06, 2015 11:50 pm

Re: Feedback for version 0.9a here

Postby JayDubya » Tue Jun 12, 2018 2:46 pm

WOW! Great job! The user interface looks really good.

Of Course a couple of things...
It would be handy to have scroll bars on the various setting/controlls windows. For some reason my 17inch laptop display is too short and the controls at the bottom are cut off. I do have a second monitor attached and the complete display is OK on that.

Also a Zoom feature would be handy to spread the spectral display a bit in order to cut off the 'down slope' ends of the display.

I'm sure you are working on more features so I won't say that my first impression ideas are all that important. It looks and performs quite good. I'd even guess that this SDR setup would be a good replacement for the Signal Hound SA.

Thanks for the hard work!
John
Last edited by JayDubya on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

NK7Z
Posts: 30
Joined: Fri Sep 02, 2016 1:14 pm
Contact:

Re: Feedback for version 0.9a here

Postby NK7Z » Tue Jun 12, 2018 3:58 pm

Wonderful piece of programming! I ran into no issues of any kind on the first run...

Reason: No reason

K9AQ
Posts: 27
Joined: Sat Jan 14, 2017 1:20 am

Re: Feedback for version 0.9a here

Postby K9AQ » Tue Jun 12, 2018 4:55 pm

Steve,

Thank you so much for your work.

I experiment with high power MOSFET HF amplifiers so my interests in a spectrum analyzer are: measurement of IMD, cut off characteristics of low pass filters, and harmonic suppression through the low pass filter. I can't comment on the harmonic suppression until you implement the frequency scanning beyond the 10mhz range of the "standard" SDR Play. I have not yet had an opportunity to test the software with a noise generator through the low pass filter.

I was able to run a two tone IMD test of an Electraft KX3 this morning and was pleased with the performance of the spectrum analyzer software. I really appreciate having the two cross hairs and being able to easily calculate the level of the IMD products. I used the two tone generator in the KX3 and ran the RF output into a bidirectional coupler with an RF sampling port, which I then ran through a 100 db step attenuator in front of the SDR Play.

I paused the main trace to use the cross hairs to highlight the two tone frequencies and the 5th order IMD products. I found that the performance of the cross hair positioning is very poor when the display is paused, compared to how it operates when not paused. I hope there is something that you can do to improve that.

The resolution using your software and the SDR Play is much better than my very old HP Spectrum Analyzer, and the additional controls make this better to use than "normal" SDR software.

I will be eagerly watching for updates, especially the scanned sweep width.

Don
K9AQ
Last edited by K9AQ on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

patapon
Posts: 1
Joined: Tue Jun 12, 2018 4:48 pm

Re: Feedback for version 0.9a here

Postby patapon » Tue Jun 12, 2018 5:02 pm

Hello,

I must do something wrong as I cannot launch the spectrum analyzer software.

I'm getting nothing, no message, no warning nothing.
Even when my RSP1A is disconnected from the USB, I'm not getting a warning about the fact he is not finding the RSP.
I'm currently using the SDRUno version 1.23, installed on top of the 1.22. it's running perfectly.

I'm running W10 pro 64 bits, (French version?), version 1803, installed (automatically!!!) on 08/06/2018, OS version 17134.48
the hardware is an Intel I3 with 8 GB memory.

I've tried reboot, relaunching the API, uninstalling it, re installing.

What am I doing wrong?

Is there anything I can check to solve it.
Last edited by patapon on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Paul
Posts: 236
Joined: Fri Feb 17, 2017 9:52 am

Re: Feedback for version 0.9a here

Postby Paul » Tue Jun 12, 2018 6:13 pm

Obviously very early days, but even I, as a technical numpty have had no problems installing and running the programme on an RSP2 and what a stunning product!
I would like to understand how to make a trace visible on the waterfall (I haven't yet found the controls for this my fault?) - it's just a white screen.
I did change the spectrum trace colour from white to green with no effect.
Would it be possible in the future to link to a recording?
And would it also be possible in some future iteration to measure harmonics within a given signal/transmission?
If this is asking for the moon and stars, please accept my appologies.

Reason: No reason

NK7Z
Posts: 30
Joined: Fri Sep 02, 2016 1:14 pm
Contact:

Re: Feedback for version 0.9a here

Postby NK7Z » Tue Jun 12, 2018 6:24 pm

Feature request:

1. If the Save and Load buttons could be activated to save the current state of the analyser setup it would be great. I am preparing a set of analyser screenshots showing a 500 KHz section of spectrum containing RFI, both with and without the RFI present.
Between runs I need to manually set up the bandwidth, etc. to match the first run, so things are all on the same scale etc. If that could be saved and recalled it would speed the process.

2. Perhaps a template for the naming the screenshots... Something like XXXX-Y, where XXXX can be user supplied, and Y is a date/time indicator in the form of DDMMYYHHMMSS.

I understand this might be too early for these types of requests, just thinking out loud here... Again, THANK YOU, this is far better than anything I currently have for use in documenting RFI issues.

Reason: No reason

pierref1nwz
Posts: 1
Joined: Tue Jun 12, 2018 6:52 pm

Re: Feedback for version 0.9a here

Postby pierref1nwz » Tue Jun 12, 2018 6:54 pm

Good evening,
does not work and does not even start. No error message ... nothing ...
W10 system
Regards
Last edited by pierref1nwz on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Sasan
Posts: 122
Joined: Sat Jun 27, 2015 1:15 am
Location: Berlin

Re: Feedback for version 0.9a here

Postby Sasan » Tue Jun 12, 2018 7:18 pm

First of all, thank you very much.
I found a very very small issue: the button called "Hide Controls" at the top should change its label to "Show Controls" when you click on it.
This is ok with other buttons designed as show/hide toggle, but not this one.

Reason: No reason
DF2HF, NM9A, EP2C


Return to “Spectrum Analysis”

Who is online

Users browsing this forum: No registered users and 1 guest