RSP2 Recording

General discussions
hfaero
Posts: 15
Joined: Tue Oct 04, 2016 8:24 pm

RSP2 Recording

Postby hfaero » Fri Jan 06, 2017 2:06 am

I've had a few goes at listening to my RSP2 while recording and it continually 'chuffs'. By this I mean the audio cuts in and out at a rate of about 2Hz (twice per second). I'm recording at full spectrum bandwidth but only at a 2MHz rate decimated by 8 giving me an effective RF bandwidth of 200kHz. This occurs in HDSDRPlay and SDRUno 1.12.

Increasing the sampling rate only makes the chuffing worse. My PC is an Intel i7860 running at 2.8GHz and with a full 2MHz sampling rate the CPU only consumes about 10 to 15% and that's with Google Chrome and PlanePlotter both running.

The MP3 recording of the audio can be found https://hfaero.com/downloads/chuffing.mp3

Reason: No reason
Cheers,
Michael
HFAero.com
Ex-RSP1 and RSP2 Owner
Kenwood R-5000 and Longwire (9:1 Un-Un)
RTL-SDR v3
Kenwood R-5000 VHF & Diamond D130J Discone

sdrplay
Posts: 576
Joined: Wed Jan 07, 2015 7:58 am

Re: RSP2 Recording

Postby sdrplay » Fri Jan 06, 2017 7:21 am

Have you tried 2MHz sample rate without decimation? You'll probably find that one core is maxed out and that's the limiting factor on the audio processing.

Best regards,

SDRplay Support

Reason: No reason

hfaero
Posts: 15
Joined: Tue Oct 04, 2016 8:24 pm

Re: RSP2 Recording

Postby hfaero » Fri Jan 06, 2017 10:04 am

Yes, 2MHz is much worse, the chuffing is about once every 2 seconds or so, and no audio in between.

There's a video of this at https://hfaero.com/downloads/chuffing.mp4 showing 2MHz and 2MH with 8 decimation.

A check of the Win10 Performance Monitor at 2MHz with decimation 8 shows one CPU at about 20% and the other three almost idle but probably under 5% each so it doesn't look like a CPU issue.

Reason: No reason
Cheers,
Michael
HFAero.com
Ex-RSP1 and RSP2 Owner
Kenwood R-5000 and Longwire (9:1 Un-Un)
RTL-SDR v3
Kenwood R-5000 VHF & Diamond D130J Discone

hfaero
Posts: 15
Joined: Tue Oct 04, 2016 8:24 pm

Re: RSP2 Recording

Postby hfaero » Sat Jan 07, 2017 5:14 am

I should add that the subsequent recordings also stutters which makes one half of my use for the RSP2 a bit fruitless.

I did another test at VHF and just 200kHz but got the same result as my first posting.

Reason: No reason
Cheers,
Michael
HFAero.com
Ex-RSP1 and RSP2 Owner
Kenwood R-5000 and Longwire (9:1 Un-Un)
RTL-SDR v3
Kenwood R-5000 VHF & Diamond D130J Discone

hfaero
Posts: 15
Joined: Tue Oct 04, 2016 8:24 pm

Re: RSP2 Recording

Postby hfaero » Sat Jan 07, 2017 10:30 pm

Panic over!

I was trying to record to a networked share and even though I have a full 100Mbps network the final leg was from my router to a USB2.0 device where all my home networked files reside.

Even though I would have thought the throughput rate would sustain a recording at 200kHz bandwidth perhaps I'll just record to the local PC and move the files off to the share as required.

Reason: No reason
Cheers,
Michael
HFAero.com
Ex-RSP1 and RSP2 Owner
Kenwood R-5000 and Longwire (9:1 Un-Un)
RTL-SDR v3
Kenwood R-5000 VHF & Diamond D130J Discone


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest