SDRlay not recognized after update

General discussions
Sasan
Posts: 98
Joined: Sat Jun 27, 2015 1:15 am

SDRlay not recognized after update

Postby Sasan » Sat Aug 15, 2015 8:30 pm

Hi
I updated my SDRPlay to the latest version of drivers and now it is not recognized by the EXTIO !
It was working, until I updated it.
This is what I did:
First I ran the "MiricsSDRAPIInstaller_1.4.0.exe", after it was finished I ran "SDRplay_EXTIO_Installer_v3.0.exe" for both SDRSharp and HDSDR.
Now when I run either of those programs, an error dialog box is shown:
"Warning SDRPlay Hardware not found"
I also tried uninstalling everything and reboot the machine, but that didn't change anything.
I tried changing the USB port too.

OS: Windows 7 SP1 x64
Device manager screenshot:

Image
Last edited by Sasan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 626
Joined: Wed Jan 07, 2015 7:58 am

Re: SDRlay not recognized after update

Postby sdrplay » Sat Aug 15, 2015 10:15 pm

For some reason the image isn't viewable. Can you send the device manager screenshot and a screenshot of the directory listings for both SDR# and HDSDR to support@sdrplay.com and we'll try to get you up and running.

Best regards,

SDRplay Support
Last edited by sdrplay on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Sasan
Posts: 98
Joined: Sat Jun 27, 2015 1:15 am

Re: SDRlay not recognized after update

Postby Sasan » Sun Aug 16, 2015 5:58 am

Thanks
It's the screenshot:
http://imgur.com/DOr40xg

Unfortunately I don't have access to that laptop now (It is a ThinkPad T420 with 4 USB 2.0 ports)
I installed the drivers and SDR# in another laptop (Samsung with USB 3.0 ports) and it worked! (I used the same exact file that I downloaded on ThinkPad and then tuned to a local FM station and also saw the new SDRPlay EXTIO settings interface)
In the ThinkPad, the problem is the Mirics driver, because the EXTIO is correctly installed and I can even see the new settings interface (in both SDR# and HDSDR), but there seems to be a problem with the driver which is highlighted in device manager too. I uninstalled and installed the driver multiple times, tried other USB ports, rebooted the system, but no success.
What could be wrong?
Last edited by Sasan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 626
Joined: Wed Jan 07, 2015 7:58 am

Re: SDRlay not recognized after update

Postby sdrplay » Sun Aug 16, 2015 7:10 am

Can you confirm if the OS is 32bit or 64bit? I would also like to see the Driver tab of the device properties. If you can get access to that machine again, please let us know.

Best regards,

SDRplay Support
Last edited by sdrplay on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

GalloCosta
Posts: 2
Joined: Sun Aug 16, 2015 10:13 am

Re: SDRlay not recognized after update

Postby GalloCosta » Sun Aug 16, 2015 11:06 am

Hello,

I had a similar issue, the new driver was working fine until I shut the PC down (sleep mode).
When I resumed the PC afterwards, SDR# showed a hardware initialization error. The error was then persistent, even after rebooting.
After uninstalling/reinstalling the driver several times it's working again and seems to be stable.
This happened on a Toshiba Satellite Laptop with Win7 64 Bit.
Btw, I really like the SDRplay. There is no better value for the money, thank you for your great work!
Last edited by GalloCosta on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

g1hbe
Posts: 242
Joined: Sat Jan 17, 2015 3:28 pm
Location: Cheshire

Re: SDRlay not recognized after update

Postby g1hbe » Sun Aug 16, 2015 11:07 am

I had exactly the same problem. After noting that the new version was available, I decided to uninstall the old version(s) and start from scratch. I did it all in exactly the same way as I have always done, but it would not work. The EXTIO would not appear in the drop down menu in SDR#, no sign of it, even though I had carefully installed it as per instructions as usual.
I tried over and over and now have a rather messy system. Suddenly it started working after yet another try. It's working a treat (with the gap now gone!), but I wish I knew whay it was so reluctant. :(
Computer unchanged - I-3 at 2.4 GHz with Windows 8.0 Enterprise. Never had any problem before. I noted that HDSDR was working fine.
Last edited by g1hbe on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
Andy

Sasan
Posts: 98
Joined: Sat Jun 27, 2015 1:15 am

Re: SDRlay not recognized after update

Postby Sasan » Sun Aug 16, 2015 7:22 pm

sdrplay wrote:Can you confirm if the OS is 32bit or 64bit? I would also like to see the Driver tab of the device properties. If you can get access to that machine again, please let us know.

Best regards,

SDRplay Support


OS and system info:
ThinkPad T420 (Windows 7 SP1 64 bits, 8GB RAM, Core i7 CPU, four USB 2.0 ports)

Here's the driver and details tab:
http://imgur.com/G3ehnoT

I installed the driver using the new link you've provided on the Windows section of Platforms page on the website (before doing that, I uninstalled and removed the previous driver)
Last edited by Sasan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Sasan
Posts: 98
Joined: Sat Jun 27, 2015 1:15 am

Re: SDRlay not recognized after update

Postby Sasan » Sun Aug 16, 2015 7:48 pm

And here's the screenshot from my other laptop (Samsung) which the new driver works on it:
Samsung 530U (Windows 8 Enterprise 64-bit with 4 GB RAM, Core i5)

http://imgur.com/EPR4fXZ

As you see, all 3 drivers are digitally signed but in my ThinkPad, only "ksthunk.sys" is signed.
I don't know why
Last edited by Sasan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 626
Joined: Wed Jan 07, 2015 7:58 am

Re: SDRlay not recognized after update

Postby sdrplay » Sun Aug 16, 2015 8:28 pm

Thanks for the images. On the thinkpad can you physically remove the c:\windows\system32\drivers\msi2500.sys file before trying the install the driver again to see if the correctly signed version is installed?

I will pass your information onto Mirics for them to look into more detail.

Best regards,

SDRplay Support
Last edited by sdrplay on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Sasan
Posts: 98
Joined: Sat Jun 27, 2015 1:15 am

Re: SDRlay not recognized after update

Postby Sasan » Mon Aug 17, 2015 6:35 am

sdrplay wrote:Thanks for the images. On the thinkpad can you physically remove the c:\windows\system32\drivers\msi2500.sys file before trying the install the driver again to see if the correctly signed version is installed?

I will pass your information onto Mirics for them to look into more detail.

Best regards,

SDRplay Support


Well, I did that, and it didn't make any difference.
I also installed the drivers on a third system (a Core i3 PC with 16GB RAM running Windows 7 Ultimate SP1 64 bits) and it also fails like the ThinkPad!
Last edited by Sasan on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests