RSP2 ADS-B DUMP1090 hangs

General discussions
JoePPi
Posts: 1
Joined: Wed May 02, 2018 4:31 pm

RSP2 ADS-B DUMP1090 hangs

Postby JoePPi » Wed May 02, 2018 4:55 pm

I've been trying to setup my RSP2 with a Raspberry Pi 3B and the latest DUMP1090 program from the dump1090_1.3.rpi.tar.gz package. Everything appears to be working "for a while" but the decoder seems to loose the ability to decode incoming data. "For a while" is anywhere from 5 - 500 minutes. Sometimes the decode recovers after minutes to hours but the timing is not predictable.

Net result of lossing decode: number of planes tracked appears to drop to one. Several times the internal webserver shows only 1 plane tracked with ICAO hex number 000000 which does seem to get new data as the AGE colums varies. See attachment.
SDRplay DUMP1090 issue.png
SDRplay DUMP1090 issue.png (5.43 KiB) Viewed 535 times

I haven't got a clue where to start looking for a solution. modprobe usbmon (shows the communication with the RSP2) shows lots of data going back and forth.
My current solution is a stop and start of the DUMP1090 program at a 16 minute interval, however that causes a loss of connection with the MLAT servers.

Any hints? Has anyone experienced similar behaviour and found a solution? I would like to get this combination going and if its beats teh RTL solution possibly getting a dedicated RSP1A for ADS-B reception.

Thanks!
Last edited by JoePPi on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Return to “General”

Who is online

Users browsing this forum: No registered users and 10 guests