Default SSH username for the SDR Play Pi image

General discussions
NeilP
Posts: 35
Joined: Wed Apr 04, 2018 3:11 pm
Location: Jersey

Default SSH username for the SDR Play Pi image

Postby NeilP » Thu Jul 19, 2018 2:04 pm

Hi
Just installed a fresh image of the SDR Play Rasp Pi Distrubtion

But cannot SSH to it
Just get a
Connection closed by 192.168.1.49 port 22

If I swap SD cards for a fresh standard Raspbian Stretch Image I can SSH straight in with user ‘Pi’ and pwd ‘raspberry’

But the SDR Play image I cannot SSH to it

Have plugged in a monitor/keyboard/mouse and confirmed SSH is enabled, but still no joy, does not even get to the password prompt

Reason: No reason

sdrplay
Posts: 795
Joined: Wed Jan 07, 2015 7:58 am

Re: Default SSH username for the SDR Play Pi image

Postby sdrplay » Thu Jul 19, 2018 2:38 pm

You will need to:

sudo raspi-config

and use the menu system to enable remote access via SSH - it's disabled by default as a security feature.

Best regards,

SDRplay Support

Reason: No reason

NeilP
Posts: 35
Joined: Wed Apr 04, 2018 3:11 pm
Location: Jersey

Re: Default SSH username for the SDR Play Pi image

Postby NeilP » Thu Jul 19, 2018 3:15 pm

Thanks for the reply, but no...as per my question:

NeilP wrote:Have plugged in a monitor/keyboard/mouse and confirmed SSH is enabled, but still no joy, does not even get to the password prompt


I used the 'Create blank file named ssh' and drag to root of SD card method of enabling SSH.

Then used the GUI to confirm SSH was enabled..but still no.

Using the exact same procedure to create a Raspberian Stretch SD , SSH works, but not with the SDR Play image....

Reason: No reason

NeilP
Posts: 35
Joined: Wed Apr 04, 2018 3:11 pm
Location: Jersey

Re: Default SSH username for the SDR Play Pi image

Postby NeilP » Fri Jul 20, 2018 1:16 am

I've tried three times now
Re downloaded the SDR PLAY Rasp image and written fresh to new format SD card

Boot and use either the GUI config or cmd line and raspi config to enable SSH
REBOOT

go to other machine

Still get the "Connection closed by... " error

I can reboot the Pi (3B+) with a new image of Rasperian and enable SSH and get in with no issue.

Something seems 'broken ' in the SDRPlay image that prevents SSH ?

Reason: No reason

sdrplay
Posts: 795
Joined: Wed Jan 07, 2015 7:58 am

Re: Default SSH username for the SDR Play Pi image

Postby sdrplay » Fri Jul 20, 2018 11:59 pm

Try this on the RPi...

sudo dpkg-reconfigure openssh-server

Best regards,

SDRplay Support

Reason: No reason

NeilP
Posts: 35
Joined: Wed Apr 04, 2018 3:11 pm
Location: Jersey

Re: Default SSH username for the SDR Play Pi image

Postby NeilP » Sat Jul 21, 2018 6:56 am

Yes, that did it

Am guessing that maybe it is to do with each instance of a different Pi OS, although on the same machine Creating a new key?

is it possible to set the same ECDSA key on multiple SD card OS's. so I can switch SD cards = reboot = and still have access via SSH without changing the know hosts file on the machine I am connecting from?

Reason: No reason

sdrplay
Posts: 795
Joined: Wed Jan 07, 2015 7:58 am

Re: Default SSH username for the SDR Play Pi image

Postby sdrplay » Sat Jul 21, 2018 8:40 am

The original card we did had the ssh key and didn't have this problem, but it was pointed out that it was a security issue. So we took the keys off and now it appears that the keys have to be regenerated on an instance by instance basis to get ssh to work.

I'm not sure if the keys can be copied from device to device or whether they need to be regenerated each time. It would be something you could try.

Best regards,

SDRplay Support

Reason: No reason

NeilP
Posts: 35
Joined: Wed Apr 04, 2018 3:11 pm
Location: Jersey

Re: Default SSH username for the SDR Play Pi image

Postby NeilP » Sat Jul 21, 2018 11:42 am

What I thought I could try is give each SD card OS a different IP address, so same hardware has different IP. The known hosts file in the connecting computer having entry for each

If not, how do I go about putting it back ‘as it was’ so it has permanent key. Let the user choose if the risk is one they are prepared to have. I’ll do a few connects/disconnects and see what occurs

Reason: No reason

sdrplay
Posts: 795
Joined: Wed Jan 07, 2015 7:58 am

Re: Default SSH username for the SDR Play Pi image

Postby sdrplay » Sat Jul 21, 2018 12:12 pm

Once you have one setup, then you could clone the SD card to other machines - that's how the first version of the card was setup.

Best regards,

SDRplay Support

Reason: No reason

NeilP
Posts: 35
Joined: Wed Apr 04, 2018 3:11 pm
Location: Jersey

Re: Default SSH username for the SDR Play Pi image

Postby NeilP » Sat Jul 21, 2018 5:09 pm

Yes, probably easier, been looking up setting static IP addresses and I see no GUI options.

For now I have created a desktop shortcut to the .ssh folder on my Windows machine. Every time I get the error I can just click the shortcut, go to the folder and delete the known hosts file. Then when ssh’ing in I get the msg about adding the key

Reason: No reason


Return to “General”

Who is online

Users browsing this forum: No registered users and 9 guests