ubuntu 16.04: nothing works!

General discussions
Morbus
Posts: 1
Joined: Tue May 17, 2016 12:55 am

ubuntu 16.04: nothing works!

Postby Morbus » Tue May 17, 2016 1:21 am

hello,

i use the sdrplay since a few weeks via windows on my desktop-pc with different sdr software’s without any problems ... great device!

since 5 days i'm trying to run the sdrplay on my linux notebook with ubuntu 16.4 and nothing works ... really nothing
- the api driver is installed correct (done via the sdrplay website)
- gqrx is installed, but there is no choice to choose the sdrplay when i start gqrx
- osmosdr "successful" installed from synaptic but there is no software to find named osmosdr on my computer

when i type lsusb in the terminal it shows me the sdrplay as "Bus 001 Device 005: ID 1df7:2500" without other hardware information
it is possible that the driver is not installed, even though the installation was without errors?

is anybody there who is able to find out, what my problem is ?

best regards, sascha
i'm sorry for my non-perfect english ... i make the best of it. :-)
Last edited by Morbus on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DK7OB
Posts: 79
Joined: Thu Mar 24, 2016 7:14 am

Re: ubuntu 16.04: nothing works!

Postby DK7OB » Tue May 17, 2016 7:37 am

Hi Morbus,

Sdrplay does not work on Linux with gqrx out of the box.

Reason is that sdrplay's driver is not free software.

You have several choices, all of them with quite a lot of manual work and building packages from source.

1. gqrx:
1.1 Build osmosdr with non free support. See http://sdr.osmocom.org/trac/wiki/GrOsmoSDR, search for sdrplay
1.2 Install soapysdr https://github.com/pothosware/SoapySDR and soapysdrplay https://github.com/pothosware/SoapySDRPlay. Here you do not need the osmosdr with non free support.

Note: sdrplay support in stock gqrx is not tested very well (since it requires non free software). I am running a patched version of gqrx (built from source) that has fixed some of the problems and is working quite well.

2. cubicsdr
This does not use the osmosdr package, but still needs the installation of the soapysdr/soapysdrplay library. It is working quite well, but has some missing features (for me) and I do not like the user interface. But that's just me.

Also note: There are problems with the sdrplay API on Ubuntu 16.04 (See this thread: viewtopic.php?f=5&t=693 ).

So all in all the Linux support for SDRPlay currently is not very good. You can get it working, but it needs quite some work and Linux experience.

Wolf, DK7OB
Last edited by DK7OB on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

IW2DHW
Posts: 59
Joined: Wed Sep 23, 2015 7:33 pm

Re: ubuntu 16.04: nothing works!

Postby IW2DHW » Fri May 20, 2016 7:08 pm

Any news on this and other post referring to Ubuntu 16.04 problem?

This Ubuntu version is available from end of April and SDRPlay API don't work on it.

Regards

Franco Spinelli
IW2DHW
Last edited by IW2DHW on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 944
Joined: Wed Jan 07, 2015 7:58 am

Re: ubuntu 16.04: nothing works!

Postby sdrplay » Mon May 23, 2016 6:49 am

Installing Ubuntu 16.04 today so I'll get to the bottom of the problem and post a reply.

Best regards,

SDRplay
Last edited by sdrplay on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DK7OB
Posts: 79
Joined: Thu Mar 24, 2016 7:14 am

Re: ubuntu 16.04: nothing works!

Postby DK7OB » Mon May 23, 2016 12:54 pm

sdrplay wrote:Installing Ubuntu 16.04 today so I'll get to the bottom of the problem and post a reply.

Great! If you need something to be tested, don't hesitate to ask!

Wolf, DK7OB
Last edited by DK7OB on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

IW2DHW
Posts: 59
Joined: Wed Sep 23, 2015 7:33 pm

Re: ubuntu 16.04: nothing works!

Postby IW2DHW » Tue May 31, 2016 7:05 pm

>Installing Ubuntu 16.04 today so I'll get to the bottom of the problem and post a reply.

After a week from installation of Ubuntu 16.04 there is some progress?

Here, after each update to Ubuntu, I test CubicSDR with SDRPlay and I get a new crash.....

Regards

Franco Spinelli
IW2DHW
Last edited by IW2DHW on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

bilbolodz
Posts: 4
Joined: Wed May 11, 2016 9:17 pm

Re: ubuntu 16.04: nothing works!

Postby bilbolodz » Tue May 31, 2016 10:19 pm

IW2DHW wrote:Here, after each update to Ubuntu, I test CubicSDR with SDRPlay and I get a new crash.....

I can confirm these issue (Ubuntu 16.04 crash).
Last edited by bilbolodz on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Huub
Posts: 1
Joined: Fri Apr 29, 2016 7:17 pm

Re: ubuntu 16.04: nothing works!

Postby Huub » Wed Jun 01, 2016 8:56 pm

Hi,

I got CubicSDR with SDRPlay working on Ubuntu Mate 16.04 using the following procedure. Thought i'd share my experience.

I'd rather have SDRPlay running with GnuRadio / GR-OSMOCON but somehow the API driver doesn't agree with these packages. It does work but the communication between SDRPlay and GnuRadio / GR-OSMOCON seems to be half crippled.

Forgive me if i'm not complete. Lot's of different things were done to get it running and i might have forgotten to write down some steps. (It was a rewarding but also frustrating journey).

Make sure the SDRPlay device (USB) is not "hijacked" by some other driver.

First you have to install the dependancies (most of these are described on the different git installation guides) I install them when needed. (mostly in case of an error)

I tried the PPA installation method for Soapy but that didn't work.

The order of installation is really important. After every update from GIT i have to rebuild SoapySDR / SoapySDRPlay / Soapy Remote and CubicSDR in this order.

Some of the installation descriptions are copied from the installation procedures written and contributed by the makers. All credit to them for making this possible. Please no difficult questions on the procedure, i just try a lot and most of what i did is internet knowledge, not mine.

I hope this helps. (and excuse my bad english)

The steps:

Code: Select all

Some Dependancies (these i installed down the road - probably some more are needed)
sudo apt-get install automake
sudo apt-get install libgtk2.0-dev
sudo apt-get install libpulse-dev
sudo apt-get install cmake g++ libpython-dev python-numpy swig

Build and install liquid-dsp
git clone https://github.com/jgaeddert/liquid-dsp
cd liquid-dsp
./bootstrap.sh
./configure --enable-fftoverride
make -j4
sudo make install
sudo ldconfig

Build static wxWidgets:
Note: replace '~/Develop/wxWidgets-staticlib' with your own path if you prefer, remember it to be used later when building CubicSDR.

wget https://github.com/wxWidgets/wxWidgets/releases/download/v3.1.0/wxWidgets-3.1.0.tar.bz2
[ downloading.. ]
tar -xvjf wxWidgets-3.1.0.tar.bz2 
[ unpacking.. ]
cd wxWidgets-3.1.0/
mkdir -p ~/Develop/wxWidgets-staticlib
./autogen.sh
./configure --with-opengl --disable-shared --enable-monolithic --with-libjpeg --with-libtiff --with-libpng --with-zlib --disable-sdltest --enable-unicode --enable-display --enable-propgrid --disable-webkit --disable-webview --disable-webviewwebkit --prefix=`echo ~/Develop/wxWidgets-staticlib` CXXFLAGS="-std=c++0x" --with-libiconv=/usr
[ configuring.. ]
make -j4 && make install
[ building and installed to ~/Develop/wxWidgets-staticlib in this example ]


Install SDRPlay API
Download and run:
./SDRplay_RSP_MiricsAPI-1.9.4.run

SoapySDR:
git clone https://github.com/pothosware/SoapySDR.git
git pull origin master # verversen
mkdir build
cd build
cmake ..
make -j4
sudo make install
sudo ldconfig #needed on debian systems

SoapySDRPlay:
git clone https://github.com/pothosware/SoapySDRPlay.git
verversen == git pull origin master

cd SoapySDRPlay
mkdir build
cd build
cmake ..
make
sudo make install

SoapyRemote:
git clone https://github.com/pothosware/SoapyRemote.git
verversen == git pull origin master
cd SoapyRemote
mkdir build
cd build
cmake ..
make
sudo make install


Test SoapySDR:
SoapySDRUtil --info


Build CubicSDR

Note: add -DUSE_HAMLIB=1 to cmake command line to include hamlib support.

git clone https://github.com/cjcliffe/CubicSDR.git
cd CubicSDR
mkdir build
cd build
cmake ../ -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=~/Develop/wxWidgets-staticlib/bin/wx-config
make
# You can now run the build from the folder, note if you're on 32-bit linux it will be in x86/
cd x64/
./CubicSDR

Install CubicSDR (and launcher)
sudo make install

Un-install CubicSDR
sudo make uninstall
Last edited by Huub on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 944
Joined: Wed Jan 07, 2015 7:58 am

Re: ubuntu 16.04: nothing works!

Postby sdrplay » Thu Jun 02, 2016 8:10 am

Hi all,

Update... I have a new version of the API working on Ubuntu 16.04 - as we are in the middle of working on new stuff, Ubuntu 16.04 will be supported in 1.9 release of the API - which is due out soon.

Sounds like a workaround has been posted above in the short term (haven't looked at it myself)

Best regards,

SDRplay Support
Last edited by sdrplay on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

nanthtommas
Posts: 1
Joined: Wed May 25, 2016 3:36 am

Re: ubuntu 16.04: nothing works!

Postby nanthtommas » Fri Jun 03, 2016 3:47 am

Nice post. I like it. Thanks for sharing these information. :D
Last edited by nanthtommas on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason
popular bubble football:Bubble soccer


Return to “General”

Who is online

Users browsing this forum: No registered users and 6 guests