Web Interface not working dump1090

Post information or questions regarding SDRplay products here
EA3HUF
Posts: 15
Joined: Wed Mar 08, 2017 5:52 pm

Re: Web Interface not working dump1090

Postby EA3HUF » Tue Aug 22, 2017 9:17 pm

Thanks for the info.
I copied the folder public_html into usr/share/dump1090/
Is that right ?

After execution of

Code: Select all

sdrplay_dump1090 --dev-sdrplay --interactive --net --oversample


Going to http://mypiaddress:8080/ I do get the google map now, with the local and UTC time clocks running.
However I can not see any plane in the map or in the list below the two clocks. I see several lines of detected planes in the dump1090 interactive output shell, but seems they are not sent to the web page.

Help would be highly appreciated.

Best

Reason: No reason

sdrplay
Posts: 610
Joined: Wed Jan 07, 2015 7:58 am

Re: Web Interface not working dump1090

Postby sdrplay » Wed Aug 23, 2017 5:42 am

They will only appear on the map if the latitude and longitude are decoded. If you have that information in the interactive display but there are still no planes on the map then it suggests something is wrong.

The public_html directory should be somewhere that you can write to otherwise dump1090 can't create files there.

I would put it in your home account and then use the command line option to tell dump1090 where the public_html folder resides.

Best regards,

SDRplay Support

Reason: No reason

EA3HUF
Posts: 15
Joined: Wed Mar 08, 2017 5:52 pm

Re: Web Interface not working dump1090

Postby EA3HUF » Wed Aug 23, 2017 8:38 am

Info for the planes in the shell is complete for most of them.
Yesterday, I already gave write permissions to the public_html folder in /usr/share/dump1090 using

Code: Select all

sudo chmod a+rwx public_html
(I know this is overkilling) to no avail. In any case, the fact that the gmap was read after creating this folder is, I suppose, an indication that, by default, the application search the html page data on /usr/share/dump1090/public_html. Is that right ?

Following your suggestion, I situated the public_html folder in /home/pi and preventively gave full permissions as above.
I executed

Code: Select all

sdrplay_dump1090 --dev-sdrplay --interactive --net --oversample --html-dir /home/pi/public_html
However no json file was written to that folder and no planes appeared in the web client.

Then, I forced the json files to be written there with

Code: Select all

sdrplay_dump1090 --dev-sdrplay --interactive --net --oversample --html-dir /home/pi/public_html --write-json /home/pi/public_html
Several json files do appeared now in the folder but nothing in the web client. Is maybe the htpp server looking for the json files in another folder by default ?

Very frustrating. I re-read the installation guide from the sdrplay downloads site and it looks like install should be straightforward on an rpi. Help welcome

Reason: No reason

thansen
Posts: 10
Joined: Fri Jun 03, 2016 8:51 pm

Re: Web Interface not working dump1090

Postby thansen » Wed Aug 23, 2017 8:56 am

I started this thread long time ago, and never got the web interface working.
I even made a support ticket, but nothing came out of it.
It could be really nice to this working "out of the box" so to say, because I am not a Linux expert, and I have not the knowledge to get it working by myself.

Thanks

Reason: No reason

EA3HUF
Posts: 15
Joined: Wed Mar 08, 2017 5:52 pm

Re: Web Interface not working dump1090

Postby EA3HUF » Wed Aug 23, 2017 10:02 am

thansen wrote:I started this thread long time ago, and never got the web interface working.
I even made a support ticket, but nothing came out of it.
It could be really nice to this working "out of the box" so to say, because I am not a Linux expert, and I have not the knowledge to get it working by myself.

Thanks


Thanks for reporting. I absolutely agree with you.
I had the internal web server running one year ago using other branches of dump1090 but lost the function when I updated to the SDRPlay release.
I was just reading the installation .sh file inside of the .run installer and in that file there is no command to create the public_html folder.
So this installer doesn't take into account the use of the internal http server on the first place.

I did not get any success trying to create the required folders as you could see from the previous post exchanges. It is difficult to imagine what to do due to the lack of documentation and source code. It could also be a problem of google maps API, but it is difficult to say without more info on dump1090 functions and code.

This is very demotivating because with the internal web server you do not need VRS and there is the possibility to customise the web site look and create new tools.
I have on high consideration the people on sdrplay, not sure why they did not address your ticket. Hope this thread help awaken interest on this subject.

Reason: No reason

sdrplay
Posts: 610
Joined: Wed Jan 07, 2015 7:58 am

Re: Web Interface not working dump1090

Postby sdrplay » Wed Aug 23, 2017 6:00 pm

Not sure what to say. I've just copied the public_html directory to /home/pi then whilst in /home/pi I run

sdrplay_dump1090 --dev-sdrplay --interactive --net

Then on another machine I went to http://MY_PI_IP_ADDRESS:8080

and I can see the map with planes on there.

Is that what you are doing?

Best regards,

SDRplay Support

Reason: No reason

sdrplay
Posts: 610
Joined: Wed Jan 07, 2015 7:58 am

Re: Web Interface not working dump1090

Postby sdrplay » Wed Aug 23, 2017 6:02 pm

Just want to make sure you are using the latest version (the one that supports the RSP2?)

sdrplay_dump1090 --h

If you see RSP2 options then you have the right version. I don't think this will work on the windows version though, I'm assuming you are using this on a Raspberry Pi?

Best regards,

SDRplay Support

Reason: No reason

EA3HUF
Posts: 15
Joined: Wed Mar 08, 2017 5:52 pm

Re: Web Interface not working dump1090

Postby EA3HUF » Wed Aug 23, 2017 11:03 pm

Yes, I am doing exactly so.

The only differences I could see are:
- I am on a raspi3 by SSH, on the same computer where I open the map. But this should be irrelevant.
- I am working on an updated Raspbian Jessie, not on the sdrplay image.

I installed the API and sdrplay_dump1090 from the sdrplay website some 5 days ago so they are the latest versions.
It works perfect with Virtual Radar with RSP1 and RSP2. I tried both.

Not sure what to say. I could sent a picture of the shell and folders but I think this is not possible on this forum .

Where the json files are written on your system? In which folder ? I can not find them.
Only If I use the option to write the json files in a folder like public_html I can see them, but I do not know where the .js scripts in public_html look for them. In public_html/script.js there is a function that gets data from /dump1090/data.json

Code: Select all

function fetchData() {
   $.getJSON('/dump1090/data.json'

but I am not sure where this dump1090 folder should be.
In any case, when I use the option --write-json, the files I see are
-aircraft.json
-history_##.json
-receiver.json
-stats.json

but no data.json !!!

Reason: No reason

sdrplay
Posts: 610
Joined: Wed Jan 07, 2015 7:58 am

Re: Web Interface not working dump1090

Postby sdrplay » Wed Aug 23, 2017 11:38 pm

I'm also connected to RPi3 over SSH and I'm using standard Jessie image. I moved the ~/public_html directory to ~/randomDir and then added --html-dir ./randomDir to the command line and this also worked fine. Removing the directory stopped it working, so it's clearly required.

This is the contents of my public_html directory - no files are added when sdrplay_dump1090 is running, so I assume they are being served to the web page from memory.

Code: Select all

-rw-r--r-- 1 pi pi  5137 Apr 19  2016 config.js
drwxr-xr-x 2 pi pi  4096 Jan  4  2017 coolclock
drwxr-xr-x 2 pi pi  4096 Jan  4  2017 db
-rw-r--r-- 1 pi pi  3806 Apr 19  2016 dbloader.js
-rw-r--r-- 1 pi pi 20341 Apr 19  2016 flags.js
drwxr-xr-x 2 pi pi 12288 Jan  4  2017 flags-tiny
-rw-r--r-- 1 pi pi  3450 Apr 19  2016 formatter.js
-rw-r--r-- 1 pi pi 11419 Apr 19  2016 gmap.html
-rw-r--r-- 1 pi pi 11277 Apr 19  2016 markers.js
-rw-r--r-- 1 pi pi 17106 Apr 19  2016 planeObject.js
-rw-r--r-- 1 pi pi 33014 Apr 19  2016 script.js
-rw-r--r-- 1 pi pi 80649 Apr 19  2016 spinny.gif
-rw-r--r-- 1 pi pi  2072 Apr 19  2016 style.css


Is this the same as yours? I can tar it up and drop you a link to it if that helps?

Best regards,

SDRplay Support

Reason: No reason

sdrplay
Posts: 610
Joined: Wed Jan 07, 2015 7:58 am

Re: Web Interface not working dump1090

Postby sdrplay » Wed Aug 23, 2017 11:40 pm

Link to the public_html I'm using...

http://www.sdrplay.com/software/public_html.tar.gz

Best regards,

SDRplay Support

Reason: No reason


Return to “SDRplay related”

Who is online

Users browsing this forum: No registered users and 2 guests