GNURadio Xterm and compatibility Failiure

Post information or questions regarding SDRplay products here
Carlos
Posts: 1
Joined: Mon Dec 11, 2017 12:07 pm

GNURadio Xterm and compatibility Failiure

Postby Carlos » Mon Dec 11, 2017 12:23 pm

Good day everyone,

For my Final project I installed the GNU Radio and UHD (USRP Drivers) following the directions of this website: https://files.ettus.com/manual/page_install.html

I chose the mode "by source" downloading the Usrp and GNU Radio. Everything went well but when I open the GNU Radio (it recognizes my Ettus B200), make the Flow Graph and execute it, it appears the following messages:

1. "The xterm executable is missing. You can change this setting in your gnuradio.conf, in section [grc], 'xterm_executable' "

2. "GR-UHD detected ABI compatibility mismatch with UHD library
GR-UHD was build against ABI: 3.9.0-0,
but library reports ABI: 3.10.2
Suggestion: install an ABI compatible version of UHD, or rebuild GR-UHD component against this ABI version"

- So the issue is that I dont know what to do with the "xterm" because I dont have it and i dont know how to create it.What can I do?
- And for the second one, I rebuild and reinstall GNU Radio and UHD several times and still doesnt work, maybe because I was doing it by "code resource". Maybe should I do it by PyBomb? Several people insist on PyBomb because it is said it resolves the compatibility problems. It is true?



Best regards to everyone and thank you a lot for your time,
Carlos
Last edited by Carlos on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

N4TKO
Posts: 15
Joined: Thu Apr 21, 2016 3:44 am

Re: GNURadio Xterm and compatibility Failiure

Postby N4TKO » Tue Dec 12, 2017 1:29 am

you didn't happen to mention what operating system you are using, but it sounds like linux. xterm is a linux program that opens a command line window. xterm, or another terminal window program like it should be found in the /usr/bin folder. other similar programs will also work, but you need to set the name in /etc/gnuradio/conf.d/grc.conf on the xterm_executable= line. other terminals that might be present on your system are uxterm, gnome-terminal, terminator, guake, yakuake, roxterm, eterm, rxvt, LXterminal, wterm, konsole, termkit, st, or xfce4-terminal. in the grc.conf file you would edit the line to read:

Code: Select all

xterm_executable=/usr/bin/gnome-terminal 

if you have gnome-terminal available. you need the path to the file and the filename. you should be able to use a file manager to navigate to /usr/bin and see which terminal program is available.

as far as the compile problem with different versions of libraries goes, i run into it all the time, and the best solution i can find is here: https://stackoverflow.com/questions/2085427/link-with-an-older-version-of-libstdc
which seems to be similar to the problem you are having... apparently the fix is to install an older version of the compiler itself.

Reason: No reason


Return to “SDRplay related”

Who is online

Users browsing this forum: No registered users and 4 guests