Beta release of gr-osmosdr for Gnu Radio and GQRX

Post information or questions regarding SDRplay products here
Posts: 2
Joined: Thu Sep 29, 2016 7:37 pm

Re: Beta release of gr-osmosdr for Gnu Radio and GQRX

Post by bjzq888 » Sun Jul 22, 2018 5:25 am

I'm running on a brand-new install of Ubuntu 18.04. I went through the instructions religiously. At the end when I ran the block for GNURadio Companion:

source ~/prefix/
PYTHONPATH=~/gr-osmosdr/lib/python-2.7/dist-packages:$PYTHONPATH \
gnuradio-companion starts and I see the SDRPlay Source in the list. However when I run a graph with that block included, I get the dreaded "no supported devices found" error. I have it plugged in, the device shows up in lsusb, and disappears when I unplug it. When I did the build for gr-osmosdr, it says that "SDRplay RSP (NONFREE)" is enabled. I've tried multiple USB ports.

When I start gnuradio-companion, the terminal window has this:

gr-osmosdr v0.1.4-144-g65652c99 (0.1.5git) gnuradio

...which seems to indicate that it's found the version of gr-osmosdr that I installed according to the instructions.

Is there something else I should be looking for?

Thank you for your help with this, I can supply any other information you might need.
Last edited by bjzq888 on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Post Reply