Page 1 of 1

SDRPlay and GQRX

Posted: Fri Jun 01, 2018 9:53 pm
by hfaero
I have a laptop with a new installation of Ubuntu 18.04 LTS and want to install GQRx to drive reception from my RSP2. I have followed some installation guides starting with the SDRPlay API for 'non windows' followed by some very ambiguous guides around the pre-requisites such as GNU Radio, gr-osmosdr, soapysdr and soapysdrplay and finally installing GQRx.

After each iteration of an installation process GQRx does not see SDRPlay and I'm gettng the idea that despite some lucky users who have a Linux installation working with an SDRPlay device I',m thinking that those must just be flukes or very clever programme coders because for this layman it just isn't happening.

Can some kind folk please just step me through what the sequence of events should be similar to this sort of thing that I've already tried:

Install the SDRPlay Linux API
Install build-essentials, git and cmake
Install gr-osmosdr
Install gnuradio
Install SoapySDR
Install SoapySDRPlay
Install GQRx

Following the above process I get many errors about dependencies, items not being found, failed CMAKE file lists etc. ectc. Which all leads me to believe that there is much to pre-configure than any of the installation guides and processes make out.

Is there anyone who can help me? BTW I'm only needing GQRx, I don't want CubicSDR or any other UI.

Re: SDRPlay and GQRX

Posted: Sat Jun 02, 2018 4:27 am
by hfaero
After another few hours bashing the keyboard and consuming copious amounts of coffee, I finally have working Ubuntu installation with GQRx and SDRPlay.

What I did in desperation was to download the generic GQRx binary package from the GQRx website, unzip it and start GQRx using the executable in that folder. Starting it from the application downloaded either by Ubuntu software or by apt-get just never worked.

Happy days!

Re: SDRPlay and GQRX

Posted: Sun Jun 03, 2018 7:31 am
by vk7jj
I finally have working Ubuntu installation with GQRx and SDRPlay
Thanks for your post, I didn't know Gqrx existed.

Followed your install path without any problems but Gqrx did not list the device even though -probe ran fine, blacklist was fine, etc.

Gave up and installed the generic binary as you did and its just dandy. After playing with it for an hour I really love it, it's very neat. I really enjoy the user interface and all the hoped for options are available. It works with both RSP2 and 1A (thank you SDRPlay) and runs very nicely on a very old laptop running Xubuntu.

Thanks again for the post.


Phil VK7JJ

Re: SDRPlay and GQRX

Posted: Sun Jun 03, 2018 9:41 am
by Tech_Support
The problem with all of these builds is that there as so many dependencies. All it takes is for one dependency to be updated and break support for the RSPs and building from scratch will no longer work. What you can build one day can the very next day fail.


SDRplay Tech_Support

Re: SDRPlay and GQRX

Posted: Mon Jun 04, 2018 8:42 am
by vk7jj
What you can build one day can the very next day fail.
Understood and sympathies, keeping stuff like that updated is truly a Sisyphean task :-)

BTW the Macintosh binary of Qqrx works straight out of the box. It's not as up to date a version as Linux but it's nice and stable and offers a real option for OSX users.

Given the lack of options for Mac it's a genuinely useful product and good enough to include a link to on your download page, being a binary makes it much less boulder like.

Note: your Mac API/HW driver must be downloaded first

Re: SDRPlay and GQRX

Posted: Sat Jun 16, 2018 3:40 am
by vk7jj
Gqrx has been really great on my Mac for the last few weeks, I've come to like it a lot and use it on Linux and OS-X

It was a little flaky though, more often than not after being launched for the first time in a while it would fail to find the RSP hardware.

Trying to fix that I downloaded and reinstalled the API/HW DRIVER – V2.11 (15TH NOV 2017) from the Mac SDRplay downloads.

And that killed it properly. I thrashed around in annoyance at myself for ages, re-downloading Gqrx Macintosh binaries and even rebuilding it entirely from source using MacPorts. Finally I hit upon the solution: Gqrx appears to rely not just on the SDRPlay drivers but on SoapySDRPlay.

I'm familiar with Soapy from Linux but had not installed it on my Mac. Installing the Macintosh version is easy (from here Using Terminal:

git clone
cd SoapySDRPlay
mkdir build
cd build
cmake ..
sudo make install

The OS-X binary version of Gqrx (available here now (mostly) finds the SDRPlay hardware with it's appropriate antenna options etc and works very well with both RSP2 and RSP1A.

"Mostly" becomes "every time" for me when I run CubicSDR first, use Cubic to select my RSP1A or 2, quit Cubic, then immediately run Gqrx.

Of course there is a small learning curve and everyone's mileage is going to vary but it's really sweet and great for HF DX and has a very neat simple memory-file system. Forgive the extremely crappy band conditions, it's been very noisy and a closed band for the last several days here.

Regards, Phil VK7JJ

Gqrx.jpg (153.67 KiB) Viewed 17436 times

Re: SDRPlay and GQRX

Posted: Wed Jun 27, 2018 1:26 am
by vk7jj
Finally got remote control of the Linux version of Gqrx via TCP for mode, audio filter width and frequency changes.

Next effort will be trying to use it's remote UDP audio server.

For anyone interested, Gqrx has an inbuilt server that receives and responds to raw TCP packets. The gotcha that held me back was not understanding that in it's Allowed Hosts settings, ip addresses have to be prefixed with ::ffff:

eg. to permit access from a Pi on the Allowed Host setting is ::ffff:

It's easy to telnet in to have a play:

me:~ Phil$ telnet 7356
Connected to
Escape character is '^]'.
Connection closed by foreign host.
me:~ Phil$

I managed to work out how to code node.js to send and receive raw TCP packets for a different client on a different port while still running a web server, so that Gqrx is able to "scan" at better than 100ms per frequency using my current scanner app. Have yet to implement stop on busy but it looks hopeful because of the high speed TCP link as opposed to serial. It doesn't have a busy signal but does give accurate signal strength. More info here for anyone interested:

Sincerely, Phil VK7JJ

Re: SDRPlay and GQRX

Posted: Sun Sep 30, 2018 2:12 pm
by alanbarker
Just tried the instructions above to set up GQRX on my MacBook running 10.11.6 (El Capitan). On entering "cmake .." I got the following output:

CMake Error at CMakeLists.txt:7 (find_package):
Could not find a package configuration file provided by "SoapySDR"
(requested version 0.4.0) with any of the following names:


Add the installation prefix of "SoapySDR" to CMAKE_PREFIX_PATH or set
"SoapySDR_DIR" to a directory containing one of the above files. If
"SoapySDR" provides a separate development package or SDK, be sure it has
been installed.

Sorry but I'm not a software developer so don't really understand how to sort out the error. Any help appreciated. Thanks.

Re: SDRPlay and GQRX

Posted: Sun Sep 30, 2018 6:58 pm
by alanbarker
OK I hadn't downloaded and built the SoapySDR software using Brew (git clone etc. etc.) This solved the SoapySDRPlay build problem error I reported above. However I sill cannot get Gqrx to work even though it "sees" the RSP-1A. In the config I/O menu I selected "Other" as the device and "soapy=0,driver=sdrplay" as the Device String.