FLDIGI only partial waterfall.

Post information or questions regarding SDRplay products here
gjones
Posts: 6
Joined: Wed Jun 08, 2016 2:07 pm

FLDIGI only partial waterfall.

Postby gjones » Tue Jul 19, 2016 7:47 am

Hi,

I have set up fldigi based on the following post which was very useful.

http://sdrplay.com/community/viewtopic.php?t=557

However, after setting HDSDR at 14070 only an intermittent waterfall is appearing in fldigi. Could it be a computer or a driver issue?

Thanks
Last edited by gjones on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DanubeBCL
Posts: 160
Joined: Sat Jul 02, 2016 12:39 pm

Re: FLDIGI only partial waterfall.

Postby DanubeBCL » Tue Jul 19, 2016 12:25 pm

Hello,
fldigi just "listens" to any sound at the soundcard you have selected in fldigi Configure, Sound Card, Capture.
As long as you can hear uninterrupted sound from your HDSDR, fldigi should "hear" the same uninterrupted sound.
I am using VB Audio Hi-Fi Cable as a default soundcard in my system and all sounds are routed into this "virtual" soundcard input. On order to hear the sound in my speakers (because VB Audio Hi-Fi Cable is virtual and has no speaker) I told the system to play back the VB Audio Hi-Fi Cable in my speaker soundcard. This is a Windows setting in soundcard settings for recording devices.
I can hear every sound now in the speakers and fldigi can "hear" every soud as well, be it from HDSDR, SDRuno, SdrDx, Perseus, Winradio, SDRConsole, SDRsharpsomething, even from a web based SDR like the famous one in Twente, Netherlands (see image).

Thus, if you have interruptions with HDSDR, you should try another sound source. Give http://websdr.ewi.utwente.nl:8901/ a chance, tune a frequency (maybe that one in my example or anything else "decodable" you can receive) and run fldigi. You should be able to decode the sound without problems.
Should there also be stutterings, something must be wrong in your system. But I cannot exactly tell you, what, because I never saw the problem. Normally a driver can not be involved.

If your PC has a "stereo mix pin" as a recording device you could also try this sound card output in fldigi. For most cases it is good enough. (I know that some manufatureres unfortunately have cancelled the "stereo mix pin" and you must use a virtual sound card.)
73s, Heinrich
Attachments
fldigi.jpg
fldigi.jpg (122.84 KiB) Viewed 2133 times
Last edited by DanubeBCL on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DK7OB
Posts: 47
Joined: Thu Mar 24, 2016 7:14 am

Re: FLDIGI only partial waterfall.

Postby DK7OB » Fri Jul 29, 2016 7:53 am

Hello DanubeBCL,

this is OT regarding SDRPlay, but I hope the message comes through anyway.

I see you are receiving DDH47 on 147.3 kHz with fldigi.

I have a problem with exactly this station. It is decoded with many errors or sometimes not at all. The signal quality is fine. The strange thing is that the signal browser decodes the station fine, but in the main window I get errors or even garbage. This happens on 147.3 but also the SW frequencies.

This happens on Linux with the the pre compiled fldigi and also with fldigi built from source using SDRPlay/gqrx or my TS590SG transceiver as signal source.

I don't see an obvious misconfiguration on my side.

Can you please share your RTTY configuration in fldigi for this station please?

Just to mention, I have no problems decoding ham radio RTTY.

TIA and best regards,
Wolf, DK7OB
Last edited by DK7OB on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DanubeBCL
Posts: 160
Joined: Sat Jul 02, 2016 12:39 pm

Re: FLDIGI only partial waterfall.

Postby DanubeBCL » Fri Jul 29, 2016 7:27 pm

Hello Wolfgang,
sorry that I cannot help. This station works with SDRuno, HDSDR, wherever the sound comes from (maybe even from the Dutch WebSDR).
My settings are:
Carrier shift 80 Hz (custom)
Baud rate 50
Baudot 5N1.5
Revers "Rv" in the main window clicked (because I am using USB resp. DIGU).
Here is a screenshot received with my Angelia PowerSDR. I have several spherics this evening, errors may occur in the text.
With SDRPlay and SDRuno a.s.o. it works just the same. This it's not off topic.
73, Heinrich
Attachments
fldigi1.jpg
fldigi1.jpg (81.13 KiB) Viewed 2040 times
Last edited by DanubeBCL on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DK7OB
Posts: 47
Joined: Thu Mar 24, 2016 7:14 am

Re: FLDIGI only partial waterfall.

Postby DK7OB » Sat Jul 30, 2016 7:25 am

Hello Heinrich,

thanks for your answer. My configuration is basically the same as yours, except I use a shift of 85 Hz.

But meanwhile I found the cause of my problems. The squelch was set slightly above zero. I don't know why, but with this station the green bar next to the squelch slider is very low, so squelch kicked in and disturbed the reception.

With squelch at zero it is now working error free.

Regards,
Wolfgang
Last edited by DK7OB on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DanubeBCL
Posts: 160
Joined: Sat Jul 02, 2016 12:39 pm

Re: FLDIGI only partial waterfall.

Postby DanubeBCL » Sun Jul 31, 2016 9:13 am

Yes, you are right. The squelch sometimes spoils decoding. I also have forgotten many times to watch the slider ;-).
BTW: 80 Hz or 85 Hz is not the problem. I believe it should be 82 Hz, but this is all within tolerance.
73, Heinrich
Last edited by DanubeBCL on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “SDRplay related”

Who is online

Users browsing this forum: Google [Bot] and 3 guests