openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Add useful snippets of code or links to entire SDR projects.
vk7jj
Posts: 126
Joined: Thu Mar 02, 2017 9:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby vk7jj » Thu Mar 01, 2018 10:22 pm

Hi rob,

Here is a link to my zipped config file

http://www.vk7jj.com/config_webrx.zip

Hope that helps.

73

Phil

Reason: No reason

robbedoeske
Posts: 14
Joined: Sun Feb 25, 2018 8:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby robbedoeske » Fri Mar 02, 2018 10:30 am

vk7jj wrote:Hi rob,

Here is a link to my zipped config file

http://www.vk7jj.com/config_webrx.zip

Hope that helps.

73

Phil


Oke thank you very much i will try and let you know.
Last edited by robbedoeske on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

robbedoeske
Posts: 14
Joined: Sun Feb 25, 2018 8:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby robbedoeske » Fri Mar 02, 2018 1:54 pm

Oke i give up, its the same problem, only big noise. I played around with sample rate, rf_gain centerfrequence and so on, at de best part i only receive some strong stations. Don,t know whats the problem. When i use the rsp2 with sdr uno on my pc everything is perfect. I make a screenshot and as you can see there are big disturbance points. They move by frequence when i chance center frequence.
Schermafbeelding 2018-03-02 om 14.43.23.png
Schermafbeelding 2018-03-02 om 14.43.23.png (239.44 KiB) Viewed 3823 times

Reason: No reason

robbedoeske
Posts: 14
Joined: Sun Feb 25, 2018 8:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby robbedoeske » Fri Mar 02, 2018 2:59 pm

This is what i see without an antenne:
Schermafbeelding 2018-03-02 om 15.49.11.png
Schermafbeelding 2018-03-02 om 15.49.11.png (199.75 KiB) Viewed 3820 times


And this is exactly your config without any changes:
Schermafbeelding 2018-03-02 om 15.52.48.png
Schermafbeelding 2018-03-02 om 15.52.48.png (205.91 KiB) Viewed 3820 times


As you see only big noise.

Reason: No reason

vk7jj
Posts: 126
Joined: Thu Mar 02, 2017 9:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby vk7jj » Sat Mar 03, 2018 5:10 am

Hi rob,

Glad to see you got it going, that was the hard part, congratulations!!

It would seem to me that what you are seeing on your screen is in fact what your RSP is receiving, surely it can be nothing else, it's nothing to do with configuration, IMHO it can only be RF, and unwanted RF by the look of it.

The fact that you see none of it when the RSP is connected to your PC means that when it's connected to your Pi, there is something different in the physical arrangement. Something in that arrangement is causing RF interference when your Pi is connected to the RSP, the obvious possibilities are

- the Pi itself, i.e all Pi's generate noise but somehow yours could be getting into your feed line or antenna in some way when in use with the RSP
- it's switch-mode power supply (the vertical green bands you see are typical of switch-mode noise)
- the Pi's ethernet connection, i.e. a CAT5 cable spreading noise from the Pi, or, bringing in RF noise from an ethernet switch
- perhaps some earthing complication
- a rearrangement of of your antenna leads or connectors

The first thing I'd do is run the Pi from a NON SWITCH-MODE power supply, i.e. a linear DC supply with an old fashioned transformer and linear regulator, even if you have to go out and buy a 5 V 3 pin regulator chip and build it yourself and connect it to a suitably old fashioned 13.8 volt linear supply. The "buck" power supplies that you see on eBay are switch mode, so don't think that's a way out, it needs to be a regulator like these

https://www.google.com.au/search?client ... 8we9ooOYAQ

Keep working at it, it's receiving!

BTW I can't easily put mine back on air or I would to show you it truly does work as expected and give you something to look forward to, my Pi is busy as part of a broadband hamnet mesh I'm playing with at the moment, but you can see from the thread that another user managed to work with mine remotely just fine.

Regards,

Phil

Reason: No reason

robbedoeske
Posts: 14
Joined: Sun Feb 25, 2018 8:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby robbedoeske » Sat Mar 03, 2018 2:15 pm

Oke thanks very much, i figured out that when i use cubic on the ip reception is also poor.
i think you are right i wil look around for a better power supply.
I let you know ;)

Reason: No reason

robbedoeske
Posts: 14
Joined: Sun Feb 25, 2018 8:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby robbedoeske » Sat Mar 03, 2018 6:56 pm

Now i use power from usb connecter from my pc and yes the big disturbing points are gone!
Reception is not as good as by sdr uno but it receives:)
I have to set rf_gain = 200, when i set it to 30 reception is very poor. Don`t know what is maximum to set.
But as so far its finally working thanks for helping !

Reason: No reason

sdrplay
Posts: 848
Joined: Wed Jan 07, 2015 7:58 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby sdrplay » Sat Mar 03, 2018 10:51 pm

200?! If you can post the RSP settings, I'll be able to help you with them.

Best regards,

SDRplay Support

Reason: No reason

vk7jj
Posts: 126
Joined: Thu Mar 02, 2017 9:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby vk7jj » Sun Mar 04, 2018 12:48 am

Hi rob; good work, you've proven the point.

It's easy to forget the Pi shares it's 5V rail with the RSP and passes all the RF crud straight through and many Pi plug packs struggle to provide enough power when peripherals are connected, causing max RFI.

Long ago in the quest to reduce noise I found I had to go linear with my Pi's, I whipped up the very rough box below using a 3 amp LM350 adjustable regulator.

LM350.JPG
LM350.JPG (40.91 KiB) Viewed 3757 times


Also use a USB hub powered again from a linear supply, to connect things to the main computer.

usb-hub.JPG
usb-hub.JPG (47.5 KiB) Viewed 3757 times


And every USB cable has this sort of treatment even if it comes with a ferrite already. The joy of multiple turns through ferrites is that the impedance presented to any common mode RF on the cable is roughly proportional to the square of the number of turns. Conversely a single pass through a ferrite is paying lip service as it presents only a few ohms impedance at best.

cables.JPG
cables.JPG (53.29 KiB) Viewed 3757 times


My stuff is rough and simple and to me it's a pain to put the time aside to do it when I'm impatient to experiment, but that's only a part of what I had to do to drop my HF noise level down to the point where I could say to myself that the noise floor on my SDR screen is determined by the performance of the SDR - and that's a good way down for an RSP :-)

Reason: No reason

robbedoeske
Posts: 14
Joined: Sun Feb 25, 2018 8:56 am

Re: openwebrx working with SDRPlay RSP2 on Raspberry Pi2B

Postby robbedoeske » Sun Mar 04, 2018 6:11 am

sdrplay wrote:200?! If you can post the RSP settings, I'll be able to help you with them.

Best regards,

SDRplay Support


What settings you need, i have a RSP2 with Raspberry pi3?

Reason: No reason


Return to “Code Corner”

Who is online

Users browsing this forum: No registered users and 4 guests