Windows API

Add useful snippets of code or links to entire SDR projects.
SDR
Posts: 1
Joined: Fri Oct 30, 2015 1:28 am

Windows API

Postby SDR » Fri Oct 30, 2015 1:37 am

I'm trying to use the windows API to control the SDRPlay. I'm calling the dll with Labview. I have the version call working, it returns the version of 1.7. Then I call the initialize function and it returns a 0 so all apears well. Then when I call the read function it returns a 10 which is saying that it is not initialized. The error codes are conflicting so at this point I'm not sure if the problem is with the init or read. Has anyone else used the API or had problems using it.
Thanks,
Mike
Last edited by SDR on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 542
Joined: Wed Jan 07, 2015 7:58 am

Re: Windows API

Postby sdrplay » Fri Oct 30, 2015 8:03 am

Hi SDR,

If you follow the sequencing shown in the example code at the bottom of the API specification document then you should be ok. If you can send screenshots or a code sample to support@sdrplay.com we'd be happy to help you get this resolved.

Best regards,

SDRplay Support
Last edited by sdrplay on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

angazu
Posts: 5
Joined: Mon May 25, 2015 6:01 pm

Re: Windows API

Postby angazu » Fri Nov 27, 2015 9:08 pm

Hi all.

I am interested in SDRplay control from Labview, but I am not an experienced programmer.

Can you be so polite to share source code to play with?

Thanks a lot.
ANgazu.
Last edited by angazu on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “Code Corner”

Who is online

Users browsing this forum: No registered users and 1 guest