MAC API Breaks GQRX

General discussions
DanaVE3DS
Posts: 3
Joined: Fri Jun 02, 2017 12:18 am

MAC API Breaks GQRX

Postby DanaVE3DS » Mon Jun 05, 2017 7:38 pm

Hi All
I have a MAC system here and prefer to use it and avoid WINDOZE like the plague...
Unfortunately when I installed the Mac API it broke GQRX and I wound up having to
re install GQRX which then broke the API.

GQRX is created and updated from code rather than just using an installer. Im wondering
if it has something to do with the Qt version?

GQRX is V 2.6.1
Qt is V 5.7.1
I don't see any mention of the SDRPlay in GrOsmoSDR either... is the API available to build?

Has anyone else had this problem?

Regards
Dana
Last edited by DanaVE3DS on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DK7OB
Posts: 47
Joined: Thu Mar 24, 2016 7:14 am

Re: MAC API Breaks GQRX

Postby DK7OB » Tue Jun 06, 2017 7:35 am

I am running Linux, but maybe its similar...

grosmosdr by default has no support for the SDRPlay. You have 2 choices:

1. Build grosmosdr with non free drivers enabled
2. Install soapysdr/soapysdrplay (preferred method). I had to build it from source.

You need quite recent versions of soapysdr and grmosdr to support the API 2.x and RSP2

Regards
Wolf, DK7OB

Reason: No reason


Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests