SoapySDDRPlay on Raspberry Pi - libusb error

Add useful snippets of code or links to entire SDR projects.
DVE
Posts: 23
Joined: Sat Mar 12, 2016 11:19 am

SoapySDDRPlay on Raspberry Pi - libusb error

Postby DVE » Sat Sep 09, 2017 1:36 pm

Hi all,

I'm trying to run SoapySDRPlay on RPi, and getting this:

1) SoapySDRUtil --info
######################################################
## Soapy SDR -- the SDR abstraction library
######################################################

Lib Version: v0.6.1-g285e72aa
API Version: v0.6.0
ABI Version: v0.6
Install root: /usr/local
Search path: /usr/local/lib/SoapySDR/modules0.6
Module found: /usr/local/lib/SoapySDR/modules0.6/libsdrPlaySupport.so
Loading modules... done
Available factories...null, sdrplay

2) SoapySDRUtil --probe
######################################################
## Soapy SDR -- the SDR abstraction library
######################################################

Probe device
SoapySDRUtil: symbol lookup error: /usr/local/lib/libmirsdrapi-rsp.so.2.10: undefined symbol: libusb_get_port_number

So, nothing works.
libusb-1.0-0-dev is already installed.

Any ideas?
Thanks.

Reason: No reason

sdrplay
Posts: 613
Joined: Wed Jan 07, 2015 7:58 am

Re: SoapySDDRPlay on Raspberry Pi - libusb error

Postby sdrplay » Tue Sep 12, 2017 12:08 am

That sounds like something has updated libusb beyond the build that is released on the RPi image (unless it's been updated recently?). Have you tried re-running the RPi API installer?

Is your starting point our RPi image download or have you used a stock OS image - iss it Raspbian?

Best regards,

SDRplay Support

Reason: No reason

DVE
Posts: 23
Joined: Sat Mar 12, 2016 11:19 am

Re: SoapySDDRPlay on Raspberry Pi - libusb error

Postby DVE » Tue Sep 12, 2017 12:47 pm

Thanks for the answer.
I'm using standard OS image on RPi2 (maybe RPi3 only supported?).

Will reinstall all and try again today evening.

Reason: No reason

DVE
Posts: 23
Joined: Sat Mar 12, 2016 11:19 am

Re: SoapySDDRPlay on Raspberry Pi - libusb error

Postby DVE » Tue Sep 12, 2017 7:20 pm

I tested it again on the second RPi.

New Raspberry Pi3 - all works ok. Don't know yet why it does not work on RPi2 though. Maybe it makes sense to do clean install and rebuild all stuff again.

Reason: No reason

sdrplay
Posts: 613
Joined: Wed Jan 07, 2015 7:58 am

Re: SoapySDDRPlay on Raspberry Pi - libusb error

Postby sdrplay » Sun Sep 17, 2017 7:49 am

You could try building/installing libusb 1.0.19 or libusb 1.0.20 from http://libusb.info/

Best regards,

SDRplay Support

Reason: No reason


Return to “Code Corner”

Who is online

Users browsing this forum: No registered users and 1 guest