RSP2 with Linux Mint

Post your feedback here
WA2ZKD
Posts: 5
Joined: Tue Dec 26, 2017 11:23 pm

RSP2 with Linux Mint

Postby WA2ZKD » Fri Dec 29, 2017 3:36 pm

Just got my RSP2. Tested it on my wife's W10 machine, so know it works with SDRuno. I'd like to use it on my Desktop, which runs Linux Mint 18 (Ubuntu 16.04). I thought I just has to run the shell script SDRplay_RSP...run and then start Cubic but I can't find SDRplay in the availble SDR choices. Looking at the out of the API stuff I see:

SoapySDR init..
API Version: v0.5.2
ABI Version: v0.5-2
Install root: ./////////
Loading modules...
[ERROR] SoapySDR::loadModule(.//////////lib/SoapySDR/modules0.5-2/libsdrPlaySupport.so)
dlopen() failed: libmirsdrapi-rsp.so.1.95: cannot open shared object file: No such file or directory
Available factories...airspy, audio, bladerf, hackrf, null, redpitaya,

It's looking for 1.95, but I see that 2.11 is what installed.

What am I doing wrong?
Last edited by WA2ZKD on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 835
Joined: Wed Jan 07, 2015 7:58 am

Re: RSP2 with Linux Mint

Postby sdrplay » Fri Dec 29, 2017 4:02 pm

Where did you get CubicSDR/SoapySDR from?

That looks like a very old version. Our non-Windows flow shows you how to build SoapySDR, SoapySDRPlay and CubicSDR for Linux (in that order)...

http://www.sdrplay.com/docs/SDRplay_non ... s_Flow.pdf

Best regards,

SDRplay Support

Reason: No reason

WA2ZKD
Posts: 5
Joined: Tue Dec 26, 2017 11:23 pm

Re: RSP2 with Linux Mint

Postby WA2ZKD » Fri Dec 29, 2017 4:09 pm

I downloaded everything from your site. It may not be clear you have to build things in every case.
Last edited by WA2ZKD on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

WA2ZKD
Posts: 5
Joined: Tue Dec 26, 2017 11:23 pm

Re: RSP2 with Linux Mint

Postby WA2ZKD » Fri Dec 29, 2017 4:10 pm

https://cubicsdr.com/

that suggests that the Cubic I used is the newest

That link is from your site
Last edited by WA2ZKD on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sdrplay
Posts: 835
Joined: Wed Jan 07, 2015 7:58 am

Re: RSP2 with Linux Mint

Postby sdrplay » Fri Dec 29, 2017 4:14 pm

Whatever SoapySDR you are using, it is an old exectuble (it's showing v0.5 and using an out of date API) - so if you use the non-Windows workflow document it will show you how to build SoapySDR and SoapySDRPlay (in that order) to get CubicSDR working with the RSP

Best regards,

SDRplay Support

Reason: No reason

WA2ZKD
Posts: 5
Joined: Tue Dec 26, 2017 11:23 pm

Re: RSP2 with Linux Mint

Postby WA2ZKD » Fri Dec 29, 2017 4:26 pm

OK now. Thanks for the help!
Last edited by WA2ZKD on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “New Users' experiences”

Who is online

Users browsing this forum: No registered users and 2 guests