periodic "wobbling" of the LO in SDRPlay radios

Post information or questions regarding SDRplay products here
N4TKO
Posts: 15
Joined: Thu Apr 21, 2016 3:44 am

periodic "wobbling" of the LO in SDRPlay radios

Postby N4TKO » Tue Jan 02, 2018 4:24 pm

i've been experiencing a minor problem with both SDRPlay -1 and -2 radios when running them on GQRX. occasionally they will start to "warble" once every 2 seconds. it looks as if the LO is being frequency modulated, and when there are signals being received (on all frequencies, meaning i can tune to other frequencies, and it continues to happen) i can hear a ZZZZZ-----ZZZZZ-----ZZZZZ-----ZZZZZ sound and all signals on the waterfall show up alternating solid and fuzzy. this usually happens if the radio has been running for 12-24 hours, and closing GQRX and opening it again does not stop the radio from doing it. what does stop the radio from doing it, is unplugging the USB connector, waiting a few seconds, and plugging it back in again, and restarting GQRX. i have not had this happen with a hackrf or RTL-SDR. it doesn't always happen after the radio has been running for 12-24 hours, but it does happen, maybe once a week or so, and when it happens, will start suddenly. i don't know if this happens on other software, since i use GQRX almost all the time. i have CubicSDR installed also, but CubicSDR has a memory leak problem, and i can't run it more than an hour or two before it runs out of RAM. the problem shows up in all versions of GQRX that i have used, and through 3 or 4 different versions of the SDRPlay driver. if this were an analog radio, and i were troubleshooting it, i would say that the PLL for the LO is drifting out of lock, and would first be looking at the phase detector or loop filter to find out why.

Reason: No reason

Return to “SDRplay related”

Who is online

Users browsing this forum: No registered users and 13 guests