Mute SDRUno during transmit

Discussions about everything to do with SDRuno
n3hkn
Posts: 18
Joined: Sat Jan 27, 2018 7:17 pm

Mute SDRUno during transmit

Postby n3hkn » Sun Jun 17, 2018 4:40 pm

I bought the RSP1A to use with my FT-450D. Reason - audio on the FT-450D was not good. Noise reduction has the usual ancient muddy stuff. SDRUno is 10 times better. Setup is the radio receiving with an amplified loop and sending with an attic dipole. Controlled by a PTT managed switch box to turn on xmit antenna during transmit and disconnect the loop during transmit.

For this new setup I connect the transmit antenna directly to the FT-450D and connect the loop, via its switch box, to the PC/SDRUno.. Electrically this works. The problem is that the RSP1A remains in active receive (SDRUno) during transmit and sees the transmitted signal, playing the content of the transmission. Is there a way to mute SDRUno during transmit.
Dick N3HKN
Last edited by n3hkn on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

n3hkn
Posts: 18
Joined: Sat Jan 27, 2018 7:17 pm

Re: Mute SDRUno during transmit

Postby n3hkn » Sun Jun 17, 2018 11:24 pm

Found the answer in a footnote in the manual: Use the "T" key. Single click places SDRuno in transmit as well as the transceiver. It also mutes the audio to prevent feedback from monitoring while transmitting. Clicking the T key or the microphone returns to monitor mode. Problem solved. :)
Last edited by n3hkn on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Roger
Posts: 139
Joined: Fri Dec 29, 2017 7:59 pm

Re: Mute SDRUno during transmit

Postby Roger » Mon Jun 18, 2018 3:39 pm

If you connect SDRuno to the FT-450D via Omni-Rig when you transmit the FT-450D will send a command to Omni-Rig that it is in transmit mode and this will be passed to SDRuno so that it will automatically mute.

Reason: No reason

swanawood
Posts: 1
Joined: Wed Oct 10, 2018 7:21 pm

Re: Mute SDRUno during transmit

Postby swanawood » Wed Oct 10, 2018 7:31 pm

Hi
I just came across this, and I found a solution (I also have a 991)

My setup is ominirig+991+sdr uno as well.

After digging into CAT manual and ominirig INI file I found that the ini is wrong because when I press PTT via the pedal attached to my 991 the correct parameter given by the radio to omnirig is 2 and not 1 as written in the ini file;
I put here the relevant final part of 991.ini coming from original installation:

[STATUS6]
Command=(TX;)
ReplyEnd=(;)
Validate=(TX.;)
Flag1=(..0.)|pmRX
Flag2=(..1.)|pmTX


to be changed in :

[STATUS6]
Command=(TX;)
ReplyEnd=(;)
Validate=(TX.;)
Flag1=(..0.)|pmRX
Flag2=(..2.)|pmTX

looking into CAT manual of 991 the syntax of CAT command parameter "TXP1;" is :
P1
0: RADIO TX “OFF” CAT TX “OFF”
1: RADIO TX “OFF” CAT TX “ON”
2: RADIO TX “ON” CAT TX “OFF” (Answer)

apparently when you press the ptt on the radio, it answer back TX2;
And now it works (for me)....

Hope this help you guys!
Cheers
Last edited by swanawood on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “SDRuno”

Who is online

Users browsing this forum: No registered users and 5 guests