RSPduo and Qt-dab

Discussions about everything to do with SDRuno
Patrick73
Posts: 25
Joined: Thu May 31, 2018 9:39 am

RSPduo and Qt-dab

Postby Patrick73 » Thu Jul 12, 2018 11:58 am

Hi there !

Does Qt-dab software (to listen to DAB stations) work with a RSPduo ?
Attached is a screenshot of the "no library or device" that shows up when selecting 'sdrplay' as a device'.

Thanks.
Attachments
qt.JPG
qt.JPG (264.92 KiB) Viewed 1107 times

Reason: No reason

Patrick73
Posts: 25
Joined: Thu May 31, 2018 9:39 am

Re: RSPduo and Qt-dab

Postby Patrick73 » Thu Jul 12, 2018 12:15 pm

The following message also shows : "failed to locate API registry entry, error = 0"

Reason: No reason

M1CRX
Posts: 1
Joined: Thu Jul 19, 2018 6:51 pm

Re: RSPduo and Qt-dab

Postby M1CRX » Thu Jul 19, 2018 6:59 pm

Any progress on getting DAB working with the RSPduo under WIndows yet?
Last edited by M1CRX on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Patrick73
Posts: 25
Joined: Thu May 31, 2018 9:39 am

Re: RSPduo and Qt-dab

Postby Patrick73 » Thu Jul 19, 2018 7:46 pm

I just received the following from Jan, Qt-dab author :
"I had contact with Andy from sdrplay. The qt-dab software does not need the v3.0 library, it all just works fine with the 2.13 library.
So, you have to install the 2.13 API from sdrplay - it can coexist with the 3.0 library.

The 2.13 library has partial support for the duo: you just use one of the tuners then, but that is all what is needed.

The sdrplay site has it its download section the 2.13 api"

Will give it a try tomorrow

Reason: No reason

Patrick73
Posts: 25
Joined: Thu May 31, 2018 9:39 am

Re: RSPduo and Qt-dab

Postby Patrick73 » Thu Jul 19, 2018 7:59 pm

To SDRplay Team : once API v2.13 is installed, does the v3.0 library remain the default one ? (in case I want to run dual tuner)
I just downloaded v2.13 but not installed yet ...

Reason: No reason

Patrick73
Posts: 25
Joined: Thu May 31, 2018 9:39 am

Re: RSPduo and Qt-dab

Postby Patrick73 » Sun Jul 22, 2018 12:14 pm

M1CRX wrote:Any progress on getting DAB working with the RSPduo under WIndows yet?


Qt-dab works after I installed API 2.13, but I still haven't managed to decode the only multiplex available at my location. The strange thing is that reception of this multiplex is quite easy with a tiny Sony radio (XDR-P1DBP) or a Roberts radio (Stream 93i).
I carefully tried to adjust at best the gain slider, in vain. The "Sync' detector sometimes blinks for a second or two, that's all.

I also gave a try to sdr-j-fmreceiver (0.99) contained in Qt-dab zip folder : only my loudest FM stations could be heard, even adjusting properly the gain slider below overloading point (tones of 'ghosts frequencies' appear otherwise).
Of course, no problem to catch dozens of stations when running SDRuno.

I don't know if both 'issues' are linked but there's something going wrong.

Reason: No reason

Patrick73
Posts: 25
Joined: Thu May 31, 2018 9:39 am

Re: RSPduo and Qt-dab

Postby Patrick73 » Thu Jul 26, 2018 7:49 pm

Jan just sent me a new release of Qt-dab 2.0 and ... At last it works !
Attachments
dab.JPG
dab.JPG (174.97 KiB) Viewed 828 times

Reason: No reason

pnoelw
Posts: 6
Joined: Sun Feb 19, 2017 2:07 pm

Re: RSPduo and Qt-dab

Postby pnoelw » Fri Jul 27, 2018 1:33 pm

.....unfortunately it now doesn't work with the RSP2! Comes up with "Warning SDRplay:no library or device" and "Could not find mir_sdr_rspDuo_TunerSel"
Previous release of Qt-dab v2.0 worked just fine.
Noel.
Last edited by pnoelw on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

Tech_Support
Posts: 341
Joined: Mon Jun 01, 2015 7:00 pm

Re: RSPduo and Qt-dab

Postby Tech_Support » Fri Jul 27, 2018 1:37 pm

Hello Noel,
Have you installed release 2.13 of the API? This is required for this new version of qt-dab.

Sincerely

Tech_Support

Reason: No reason

pnoelw
Posts: 6
Joined: Sun Feb 19, 2017 2:07 pm

Re: RSPduo and Qt-dab

Postby pnoelw » Sat Jul 28, 2018 2:33 pm

Thanks Support
Installed 2.13 and all now fine. I hadn't installed earlier as it is listed as "For developers only" on the download page.
Is there any way of checking via SDRUno which API is installed?
Thanks for the update and assistance.
Noel.
Last edited by pnoelw on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “SDRuno”

Who is online

Users browsing this forum: No registered users and 9 guests