CubicSDR Build Issues

Post your feedback here
ehidle
Posts: 3
Joined: Sat Jan 07, 2017 8:53 pm

CubicSDR Build Issues

Postby ehidle » Mon Dec 31, 2018 3:20 am

At one point in history I had an SDRPlay working in Ubuntu. Starting with Skywave Linux (which oddly claims SDRPlay functionality out of the box), and rebuilding practically the entire system from source, CubicSDR still fails when trying to initialize the SDRPlay (the CubicSDR that comes packaged with skywave cannot even see the SDRPlay).

I have rebuilt soapy, the soapy module, and all the things (aaaaaaalllll the things) that are required to build Cubic. All seem to build and install okay, except, Cubic jump off a building when it sees the SDRPlay.

I get this from the console:

[code]Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "topmenu-gtk-module"
Loading:: configuration file '/home/ehidle/.CubicSDR/config.xml'

(CubicSDR:31136): IBUS-WARNING **: Unable to load /var/lib/dbus/machine-id: Failed to open file '/var/lib/dbus/machine-id': No such file or directory

Audio Device #0 PulseAudio
Default Output? Yes
Default Input? Yes
Input channels: 2
Output channels: 2
Duplex channels: 2
Native formats:
16-bit signed integer.
32-bit signed integer.
32-bit float normalized between plus/minus 1.0.
Supported sample rates:
8000hz
16000hz
22050hz
32000hz
44100hz
48000hz
96000hz

Available vertical sync SwapInterval functions:
glxSwapIntervalEXT: No
DRI2SwapInterval: No
glxSwapIntervalMESA: No
glxSwapIntervalSGI: No
No vertical sync swap interval functions available.
Loaded font 'Bitstream Vera Sans Mono' from '/home/ehidle/software/CubicSDR-0.2.4/build/x64/fonts/vera_sans_mono12_0.png', parsed 255 characters.
Loaded font 'Bitstream Vera Sans Mono' from '/home/ehidle/software/CubicSDR-0.2.4/build/x64/fonts/vera_sans_mono16_0.png', parsed 255 characters.
Loaded font 'Bitstream Vera Sans Mono' from '/home/ehidle/software/CubicSDR-0.2.4/build/x64/fonts/vera_sans_mono18_0.png', parsed 255 characters.
Loaded font 'Bitstream Vera Sans Mono' from '/home/ehidle/software/CubicSDR-0.2.4/build/x64/fonts/vera_sans_mono24_0.png', parsed 255 characters.
Loaded font 'Bitstream Vera Sans Mono' from '/home/ehidle/software/CubicSDR-0.2.4/build/x64/fonts/vera_sans_mono27_0.png', parsed 255 characters.
SDR enumerator starting.
SoapySDR init..
API Version: v0.7.0
ABI Version: v0.7
Install root: /usr/local
Loading modules...
linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_003.010.003.000-0-unknown

Available factories...airspy, audio, bladerf, hackrf, miri, null, osmosdr, remote, rfspace, rtlsdr, sdrplay, uhd
usb_claim_interface error -6
default_input = True
default_output = True
device_id = 0
driver = audio
label = PulseAudio
Make device 0
device_id=0
origin=https://github.com/pothosware/SoapyAudio

driver = miri
label = Mirics MSi2500 default (e.g. VTX3D card)
miri = 0
Make device 1
Using device #0: Mirics MSi2500 default (e.g. VTX3D card)
_mirisdr_alloc_async_buffers
Lost samples!
Lost samples!
OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO/code]

And the zeroes continue indefinitely until I kill the process.

The only thing I see in here that I can envision might be an issue here is the "usb_claim_interface error -6" message. I can't see that anything else is trying to use the device, though.

Any guidance?
Thanks in advance!
Last edited by ehidle on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

someYguy
Posts: 102
Joined: Sun Apr 10, 2016 7:12 pm

Re: CubicSDR Build Issues

Postby someYguy » Tue Jan 01, 2019 5:30 pm

I once installed Skywave on an old Dell Optiplex 360 with no issues and it did see and work with the SDRPlay RSP1. But after using GQRX, CubicSDR, etc. for awhile I realized that these programs are somewhat lacking compared to their Windows counterparts and so I reformatted the computer and went with Windows 7 and HDSDR for HF.

But my Skywave install did work as it was supposed to on that computer and so I'm wondering if your issue is maybe hardware or driver related?

Reason: No reason

sdrplay
Posts: 891
Joined: Wed Jan 07, 2015 7:58 am

Re: CubicSDR Build Issues

Postby sdrplay » Mon Jan 07, 2019 11:53 am

Please note that...

Make device 1
Using device #0: Mirics MSi2500 default (e.g. VTX3D card)


means that this is using the reverse engineered partially working library that is nothing to do with either ourselves or Mirics.

CubicSDR should use SoapySDR which then in turn uses SoapySDRPlay and the API - this is the officially supported method.

Best regards,

Andy

Reason: No reason


Return to “New Users' experiences”

Who is online

Users browsing this forum: No registered users and 7 guests