Seeking help to build ExtIO .dll library file

Add useful snippets of code or links to entire SDR projects.
sv5dkl
Posts: 2
Joined: Tue Mar 05, 2019 5:11 pm

Seeking help to build ExtIO .dll library file

Postby sv5dkl » Tue Mar 05, 2019 5:26 pm

Hi, all.

I am trying to set up a Remote WebSDR , specifically for Amateur Radio use, e.g. listening to split frequencies in pileups from a remote site with good RX antennas.
Currently, I am running latest RPi image provided by SDRPlay Downloads section, and my Pi3b+ is doing great command of my RSP2.
Within my local LAN, I can easily get the I/Q stream of even 8 MHz to another PC, running HDSDR or CubicSDR, using RSP_TCP_Server at the Pi.
But, when I try to access the same stream from a WAN connection (from my home QTH, for instance), in HDSDR (using ExtIO_RSP_TCP.dll provided on 15th Feb. by SDRPlay), even with the lowest sampling rate supported (0.250 MSPS), received audio is intermittent.
What I have concluded to, is that I need to build a new ExtIO_RSP_TCP.dll library, from the source code mentioned in the original github repo, by editing the .cpp file at the point where several MSPS values are stated (that is, to add mine, say some values ranging from 5 KHz up to 50 or 100 KHz). That should do it (make I/Q stream "lighter").
While I've installed Visual Studio 2017 and being a hardware/networking guy since mid 90's, I still find it hard to do this myself.
Any help to build this custom .dll will be much much appreciated. Maybe others will find this useful, too.
It would be great to have an "idiot's guide" for this procedure, available at some time ...

Regards to all!

de Stathis, SV5DKL
Last edited by sv5dkl on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

sv5dkl
Posts: 2
Joined: Tue Mar 05, 2019 5:11 pm

Re: Seeking help to build ExtIO .dll library file

Postby sv5dkl » Sat Mar 09, 2019 11:00 am

Trying by myself ...

installed VS2013 and haygen's repo, plus ExtIO_RSP_TCP source code.
I am having trouble rebuilding the solution ... many C2491 errors come up,
including a IDI_SHIELD macro redefinition error message at the beginning.

It all sounds Greek to me :lol:

Anyone willing to help me out, or shall I just forget about it?

I feel I am close, but just not close enough :?
Last edited by sv5dkl on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “Code Corner”

Who is online

Users browsing this forum: No registered users and 5 guests