Problem with ALE Channel Scanning Using CAT

Discussions about everything to do with SDRuno
DaveK3DX
Posts: 2
Joined: Wed Apr 03, 2019 2:50 pm

Problem with ALE Channel Scanning Using CAT

Postby DaveK3DX » Wed Apr 03, 2019 9:00 pm

I am using ALE software to control my SDRduo receive frequencies. The ALE software has a list of channels to scan. It sends the frequency info to SDRuno (v1.3) at the rate of two per second. This works well for a limited period of time. Eventually, however, SDRuno stops responding to the frequency info sent by the ALE software. The ALE software does not know this, so it continues to send frequency data through the virtual serial port to SDRuno. SDRuno stops responding to ANY input, not just CAT; I have to kill the process. When I re-open SDRuno, it immediately begins displaying the frequency data (at 2/sec.) Eventually, SDRuno will stop responding, again. And so on.

I have tried two virtual serial port drivers, using ports 7 and 17: VSP Manager, and com0com. No difference. I enabled buffer overrun (on both 7 and 17) in com0com. No change. I selected "emulate baud rate" on and off. No difference. The ALE software has a wide choice of CAT commands. I have tried using Kenwood TS-480, and the old VSP1000 receiver (both Kenwood commands, really.) No difference. When baud rate emulation is on, it appears that SDRuno runs longer at 4800 baud than at 9200 baud, but I'm not sure.

Depending upon how many times the ALE software detects a signal and pauses scanning, it can take 2-4 hours before SDRuno stops responding. That's probably more than 10,000 successful frequency changes via CAT before SDRuno stops responding.

If I have the ALE software send data once for just one frequency, with NO scanning, SDRuno will run forever, apparently. I get tired before it does; it never dies.

I have tried this on two PCs, one running Win8.1, the other, Win10. Both are 64 bit. I have ensured that all USB ports never power down (which is obvious, because SDRuno runs just fine when not receiving all those frequency commands.)

How do I fix this? Mike (SDRplay support) has been helpful. He also suggests I try this community forum. The software I use is MARS-ALE. The developer has seen a 2015 version of SDRuno that was sensitive to baud rate (higher = bad) but that's all he says.

I hope I have said something here that inspires a solution. Feel free to ask questions.

thanks,
Dave K3DX
Last edited by DaveK3DX on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason

DaveK3DX
Posts: 2
Joined: Wed Apr 03, 2019 2:50 pm

Re: Problem with ALE Channel Scanning Using CAT

Postby DaveK3DX » Thu Apr 04, 2019 2:25 pm

MORE: In case it matters, I am scanning five frequencies between 4 and 12MHz. I have SDRuno set for a sample rate of 2MHz, with decimation of 8. When SDRuno stops responding, I almost (maybe always?) see different frequencies in the RX CONTROL and MAIN SP windows. For example, lets say that the five channels are scanned 1-2-3-4-5-1-2-3-4-5-... . Typically, when SDRuno stops responding, the MAIN SP will display (for example) channel 4, while the RX CONTROL window will display channel 5's frequency.

Also, I wonder... Is there any CAT handshaking going on? There does not seem to be. MARS-ALE happily continues to send CAT commands, even after SDRuno has stopped responding. And how long, after a CAT frequency command is received, does it take the receiver to begin sending audio on the new frequency?

thanks, Dave

PS: I tried editing my first post, but I received an obscure message in red about "poll options." No idea what that is :(
Last edited by DaveK3DX on Thu Jan 01, 1970 12:00 am, edited 0 times in total.
Reason: No reason


Return to “SDRuno”

Who is online

Users browsing this forum: No registered users and 5 guests