Web Interface not working dump1090

Post information or questions regarding SDRplay products here
Posts: 15
Joined: Wed Mar 08, 2017 5:52 pm

Re: Web Interface not working dump1090

Post by EA3HUF » Thu Aug 24, 2017 1:53 pm

OK, now is working. :P

Please note that the contents of the public_html folder in the link you gave me in a previous post:

https://github.com/SDRplay/dump1090/tre ... ublic_html

is not the same that the one you sent compressed as a .tar.gz

Yesterday night I start suspecting the problem was with the fetching of the data by the .js scripts in the public_html folder.
They were looking for data.json but the program was producing aircraft.json.

I found a comment of a developper saying he changed names in public_html javascript scripts and some related discussions on forums (https://github.com/mutability/dump978/issues/7).

This can potentially create many troubles if you are not aware of the changes and which are the specific forks of the program you need.

Anyway, many thanks for the support. Now is working and I learnt several things in the way. Fantastic
If you allow me, I would ask sdrplay people to update the installer on the sdrplay downloads page to include public_html and prevent the problem.

Reason: No reason

Posts: 978
Joined: Wed Jan 07, 2015 7:58 am

Re: Web Interface not working dump1090

Post by sdrplay » Fri Aug 25, 2017 7:44 am

Interesting that the contents are different. I will work on adding the public_html folder into the installer. Will try to get that done soon, but have to work it around other development that's going on.

Thanks for your help in getting to the bottom of the problem.

Best regards,

SDRplay Support

Reason: No reason

Posts: 20
Joined: Thu Jan 08, 2015 4:21 pm

Re: Web Interface not working dump1090

Post by Rebel » Fri Apr 19, 2019 6:10 pm


havn't used dump1090 for a while and was also struggling to get access to the web interface on my local machine.
At the end I've solved the issue by adding the net-bind-address command and all worked fine then. This was different in earlier versions I think...
The /public_html folder is subfolder of my /dump1090 folder which is located in my /home on a Ubuntu Linux
This is how I start dump/1090 in /home/user/dump1090/

./dump1090 --dev-sdrplay --interactive --rsp2-antenna-portA --net --net-bind-address

Hope this helps in case someone runs into the same issue

73 de Fred, DL6BAW

Reason: No reason

Post Reply