Page 2 of 2

Re: RaspberryPi Image and No Audio

Posted: Sun Mar 10, 2019 7:41 pm
by salsero
I also have no sound with V0.4 and V0.5 on rpi3b+. V0.3 is working ok with my rsp1a. I've also updated/graded V0.5 from Stretch version 4.14.79-V7+ #1159 sun nov 4 2018 to latest Stretch version 4.14.98-V7+ #1200 Tue feb 12 2019 and also tried to set audio in raspi-config to HDMI only, all to no avail. And I also have no sound on Youtube ...
However, CubicSDR is starting much faster on V0.5 compared to V0.3


Re: RaspberryPi Image and No Audio

Posted: Sun Apr 14, 2019 3:37 pm
by M1ASR
I'm wondering if there is a fix for this yet?

Re: RaspberryPi Image and No Audio

Posted: Wed Jun 19, 2019 7:22 pm
by peterg
What's going on with this issue, I just purchased a raspberry pi 3b and RSP1a especially because I heard it was a good combination for a newbie. Now I have it all working except sound. So SDR is not use at all, what's the point in having a radio you cannot hear??

How about it SDRPlay, any news?

Thanks and hoping you might reply.

Re: RaspberryPi Image and No Audio

Posted: Thu Jun 20, 2019 11:32 am
by peterg
After a day of trying to get the sound working I finally figured it out.

The only way I can get it to work is to unplug the hdmi cable and ssh into the PI.

Then I installed the pulse audio sound control

Code: Select all

pi@pi3b:~ $ sudo apt-get install pavucontrol
The I tried to start the pulse audio daemon.

Code: Select all

pi@pi3b:~ $ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {89554ab4bad045b8b0d8e60686cb91f2}unix:/run/user/1000/pulse/native, refusing to start/autospawn.
Not work so the pulse audio does not see to start up. Found this fix

Code: Select all

pax11publish -r
Now I have sound.

These URL's were helpful.... ... tup_failed ... ooting.htm

Re: RaspberryPi Image and No Audio

Posted: Tue Jun 25, 2019 3:58 pm
by lifeatluthien
Similar but also different problem here, v0.5 image. I was getting audio but only out of the HDMI interface no matter what settings I tried using. Plugging in a USB sound card didn't change things; although the software reported seeing the device, it was ignored when trying to use it to get audio out.
BUT - the audio was totally distorted, like the volume was maxing out. The volume controls (either on the speaker icon or in the Preferences -> Audio devices panel were ignored, with the exception of muting it - sometimes.
I tried the Pulse Audio fixes above, but that didn't change things. But then went all out and installed almost everything I could find mentioning Pulse Audio in the Add/Remove Software dialogue. This gave me an increased set of controls, and I can now get undistorted audio out of my USB sound card.
So that's progress, but as yet I don't know which particular software package made the difference. If I have time I'll re-image the SD card and go through methodically adding packages to see what makes the difference.
It is, however, totally frustrating that the v0.4 and v0.5 builds are not working by default. My standard Raspbian build works exactly as expected, so this begs the question of what has broken in this particular build from SDRPlay?

Re: RaspberryPi Image and No Audio

Posted: Fri Jun 28, 2019 7:50 pm
by Raptor30k
I'm running my Pi headless (no HDMI conntection), don't know if this has any effect.

I had to go to the Pi applications menu (corner of desktop), Preferences, Audio Device Settings and move the PCM slider from the bottom to the top.

With Gqrx I also had to go to File, I/O Devices menu and change Audio Input from dmix to Default.

Don't know about other programs.

I'm fighting another problem (I'll post separately)... In gnuradio I'm getting audio stuttering with Au (audio underrun) messages. When I set Debug to True in RSP1 Source, I get USB Overflow messages. Also see audio underrun messages in Gqrx.