Page 1 of 1

Gqrx?

Posted: Fri Feb 01, 2019 11:59 pm
by arcosine
Im trying to get Gqrx running on Ubuntu. it says to call cmake with these parameter, but this is my result:


Instructions:

SDRplay Source

The sdrplay source uses a precompiled (closed source) library available from http://www.sdrplay.com/api_drivers.html to interface with the hardware. To enable this nonfree driver you have to call cmake with the additional parameter -DENABLE_NONFREE=TRUE
Argument Notes
sdrplay Use this argument without a value

Result:

Tony@tony5:~$ cmake -DENABLE_NONFREE=TRUE
CMake Error: The source directory "/home/tony" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
tony@tony5:~$

If I run it in the usr/share director I get the same result.

Im at a loss.

Tony

Re: Gqrx?

Posted: Sat Feb 02, 2019 4:03 pm
by fventuri
Tony,
since you don't say much what you did before running 'cmake', I assume you are trying to build gr-osmosdr with support for SDRplay RSPs, as described here https://osmocom.org/projects/gr-osmosdr/wiki/GrOsmoSDR.

If this is the case (please correct me if I am wrong), these are the commands you need to run before 'cmake':

Code: Select all

git clone git://git.osmocom.org/gr-osmosdr
cd gr-osmosdr/
mkdir build
cd build/
cmake -DENABLE_NONFREE=TRUE ../

The reason I am pointing this out is because from your output it looks like you are trying to run 'cmake' in your home directory (since your command prompt shows '~'), instead of something like '/home/Tony/gr-osmosdr/build'.

Hope this helps,
Franco

Re: Gqrx?

Posted: Sat Feb 02, 2019 7:25 pm
by ON5HB
Franco you forgot the last bits:

Code: Select all

make


and

Code: Select all

sudo make install